Supply chain compromise via malicious @cap-js/openapi
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cap-js/openapi 1.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @cap-js/openapi
- Affected
- >= 1.4.1, <= 1.4.1
- Fixed in
- 1.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpvj-wpmj-h7rv lists affected ranges: npm @cap-js/openapi >=1.4.1 <=1.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jpvj-wpmj-h7rv lists affected ranges: npm @cap-js/openapi >=1.4.1 <1.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact On May 19, 2026, a compromised version of @cap-js/openapi@1.4.1 was published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. Patches Upgrade to @cap-js/openapi = 1.4.2 If the compromised version was ever installed, rotate all affected credentials. Workarounds No workarounds. References - SAP Note 3747787 - Developer FAQ
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jpvj-wpmj-h7rv
- Revision 2 · amended ·
Amended from osv record GHSA-jpvj-wpmj-h7rv
- Revision 1 · created ·
Published from ghsa record GHSA-jpvj-wpmj-h7rv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-jpvj-wpmj-h7rv Advisory: Supply chain compromise via malicious @cap-js/openapi IDs: GHSA-jpvj-wpmj-h7rv Record: https://patchnext.com/advisories/ghsa-jpvj-wpmj-h7rv (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @cap-js/openapi 1.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @cap-js/openapi: affected >= 1.4.1, <= 1.4.1; fixed in 1.4.2 ## Suggested inspection (read-only) - `npm ls @cap-js/openapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @cap-js/openapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jpvj-wpmj-h7rv (GitHub-reviewed advisory GHSA-jpvj-wpmj-h7rv lists affected ranges: npm @cap-js/openapi >=1.4.1 <=1.4.1) - Verified: https://osv.dev/vulnerability/GHSA-jpvj-wpmj-h7rv (OSV record GHSA-jpvj-wpmj-h7rv lists affected ranges: npm @cap-js/openapi >=1.4.1 <1.4.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…