UnratednpmAmendedPublished
Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)
CVE-2026-46421 · GHSA-pvw4-cvr4-97p8
- Affected
- npm @cap-js/db-service >= 2.10.1, <= 2.10.1
- Fixed in
- 2.11.0· Vendor fix available
- Issue
- Impact On April 29, 2026, compromised versions of @cap-js/sqlite@2.2.2, @cap-js/postgres@2.2.2, and @cap-js/db-service@2.10.1 were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. Patches Upgrade to @cap-js/sqlite = 2.4.0, @cap-js/postgres = 2.3.0, @cap-js/db-service = 2.11.0. If a compromised version was ever installed, rotate all affected credentials. Workarounds No workarounds.
Recommended action: Upgrade to 2.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.