Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)
CVE-2026-46421GHSA-pvw4-cvr4-97p8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cap-js/sqlite 2.3.0; @cap-js/postgres 2.3.0; @cap-js/db-service 2.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @cap-js/sqlite
- Affected
- >= 2.2.2, <= 2.2.2
- Fixed in
- 2.3.0
npm @cap-js/postgres
- Affected
- >= 2.2.2, <= 2.2.2
- Fixed in
- 2.3.0
- Affected
- >= 2.10.1, <= 2.10.1
- Fixed in
- 2.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pvw4-cvr4-97p8 lists affected ranges: npm @cap-js/sqlite >=2.2.2 =2.2.2 =2.10.1 <=2.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pvw4-cvr4-97p8 lists affected ranges: npm @cap-js/sqlite >=2.2.2 =2.2.2 =2.10.1 <2.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-46421: 0.52% estimated exploitation activity in the next 30 days; percentile 44.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact On April 29, 2026, compromised versions of @cap-js/sqlite@2.2.2, @cap-js/postgres@2.2.2, and @cap-js/db-service@2.10.1 were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. Patches Upgrade to @cap-js/sqlite = 2.4.0, @cap-js/postgres = 2.3.0, @cap-js/db-service = 2.11.0. If a compromised version was ever installed, rotate all affected credentials. Workarounds No workarounds.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pvw4-cvr4-97p8
- Revision 2 · amended ·
Amended from osv record GHSA-pvw4-cvr4-97p8
- Revision 1 · created ·
Published from ghsa record GHSA-pvw4-cvr4-97p8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46421 Advisory: Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service) IDs: CVE-2026-46421, GHSA-pvw4-cvr4-97p8 Record: https://patchnext.com/advisories/cve-2026-46421 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @cap-js/sqlite 2.3.0; @cap-js/postgres 2.3.0; @cap-js/db-service 2.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @cap-js/sqlite: affected >= 2.2.2, <= 2.2.2; fixed in 2.3.0 - npm @cap-js/postgres: affected >= 2.2.2, <= 2.2.2; fixed in 2.3.0 - npm @cap-js/db-service: affected >= 2.10.1, <= 2.10.1; fixed in 2.11.0 ## Suggested inspection (read-only) - `npm ls @cap-js/sqlite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @cap-js/postgres --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @cap-js/db-service --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @cap-js/sqlite, @cap-js/postgres, @cap-js/db-service. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pvw4-cvr4-97p8 (GitHub-reviewed advisory GHSA-pvw4-cvr4-97p8 lists affected ranges: npm @cap-js/sqlite >=2.2.2 =2.2.2 =2.10.1 <=2.10.1) - Verified: https://osv.dev/vulnerability/GHSA-pvw4-cvr4-97p8 (OSV record GHSA-pvw4-cvr4-97p8 lists affected ranges: npm @cap-js/sqlite >=2.2.2 =2.2.2 =2.10.1 <2.11.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…