Skip to content

← Public intelligence

npm package

@builder.io/qwik

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7npmAmendedPublished

    Qwik: Crashing any Qwik Server via Resource thenable

    CVE-2026-84994 · GHSA-x586-xvc8-g7q6

    Affected
    • npm @builder.io/qwik < 1.20.0
    Fixed in
    1.20.0· Vendor fix available
    Issue
    A Qwik server in the default configuration can be crashed with one unauthenticated HTTP request. During qwik-json body parsing, ResourceSerializer.$fill$ does Promise.resolve(resource.resolved). If resolved is a plain object whose .then is a QRL for an unregistered symbol, the async QRL rejects, the rejection is orphaned, and Node terminates the process via its default unhandled-rejection policy. Impact One unauthenticated request crashes the server. Looping keeps every replica dead as long as the attacker sends requests.

    Recommended action: Upgrade to 1.20.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  2. Critical, CVSS 9.2npmAmendedPublished

    Qwik vulnerable to Unauthenticated RCE via server$ Deserialization

    CVE-2026-27971 · GHSA-p9x5-jp3h-96mm

    Affected
    • npm @builder.io/qwik <= 1.19.0
    Fixed in
    1.19.1· Vendor fix available
    Issue
    qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. Impact - Remote Code Execution

    Recommended action: Upgrade to 1.19.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  3. Medium, CVSS 5.1npmAmendedPublished

    Qwik has a potential mXSS vulnerability due to improper HTML escaping

    CVE-2024-41677 · GHSA-2rwj-7xq8-4gx4

    Affected
    • npm @builder.io/qwik < 1.7.3
    Fixed in
    1.7.3· Vendor fix available
    Issue
    A potential mXSS vulnerability exists in Qwik for versions up to 1.6.0. Details Qwik improperly escapes HTML on server-side rendering. It converts strings according to the following rules: https://github.com/QwikDev/qwik/blob/v1.5.5/packages/qwik/src/core/render/ssr/render-ssr.ts#L1182-L1208 - If the string is an attribute value: - " - &quot; - & - &amp; - Other characters - No conversion - Otherwise: - < - &lt; - - &gt; - & - &amp; - Other characters - No conversion It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). PoC A vulnerable component: If a user accesses the following URL, then, alert(123) will be executed. Impact XSS

    Recommended action: Upgrade to 1.7.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Critical, CVSS 9.8npmAmendedPublished

    builderio/qwik is vulnerable to code injection

    CVE-2023-1283 · GHSA-9wf9-qvvp-2929

    Affected
    • npm @builder.io/qwik < 0.21.0
    Fixed in
    0.21.0· Vendor fix available
    Issue
    Code Injection in GitHub repository builderio/qwik prior to 0.21.0. The Function deserializer can be accessed using the pureServerFunction feature. This allows any Javascript code to be run by node.js.

    Recommended action: Upgrade to 0.21.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 6.1npmAmendedPublished

    @builder.io/qwik vulnerable to Cross-site Scripting

    CVE-2023-0410 · GHSA-hm7f-rq7q-j9xp

    Affected
    • npm @builder.io/qwik < 0.16.2
    Fixed in
    0.16.2· Vendor fix available
    Issue
    @builder.io/qwik prior to version 0.16.2 is vulnerable to cross-site scripting due to attribute names and the class attribute values not being properly handled.

    Recommended action: Upgrade to 0.16.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →