Qwik has a potential mXSS vulnerability due to improper HTML escaping
CVE-2024-41677GHSA-2rwj-7xq8-4gx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@builder.io/qwik 1.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @builder.io/qwik
- Affected
- < 1.7.3
- Fixed in
- 1.7.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2rwj-7xq8-4gx4 lists affected ranges: npm @builder.io/qwik >=0 <1.7.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2rwj-7xq8-4gx4 lists affected ranges: npm @builder.io/qwik >=0 <1.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-41677: 0.50% estimated exploitation activity in the next 30 days; percentile 42.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A potential mXSS vulnerability exists in Qwik for versions up to 1.6.0. Details Qwik improperly escapes HTML on server-side rendering. It converts strings according to the following rules: https://github.com/QwikDev/qwik/blob/v1.5.5/packages/qwik/src/core/render/ssr/render-ssr.ts#L1182-L1208 - If the string is an attribute value: - " - " - & - & - Other characters - No conversion - Otherwise: - < - < - - > - & - & - Other characters - No conversion It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). PoC A vulnerable component: If a user accesses the following URL, then, alert(123) will be executed. Impact XSS
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2rwj-7xq8-4gx4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2rwj-7xq8-4gx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41677 Advisory: Qwik has a potential mXSS vulnerability due to improper HTML escaping IDs: CVE-2024-41677, GHSA-2rwj-7xq8-4gx4 Record: https://patchnext.com/advisories/cve-2024-41677 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @builder.io/qwik 1.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @builder.io/qwik: affected < 1.7.3; fixed in 1.7.3 ## Suggested inspection (read-only) - `npm ls @builder.io/qwik --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @builder.io/qwik. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2rwj-7xq8-4gx4 (OSV record GHSA-2rwj-7xq8-4gx4 lists affected ranges: npm @builder.io/qwik >=0 <1.7.3 (fixed)) - Verified: https://github.com/advisories/GHSA-2rwj-7xq8-4gx4 (GitHub-reviewed advisory GHSA-2rwj-7xq8-4gx4 lists affected ranges: npm @builder.io/qwik >=0 <1.7.3) Commands are suggestions: review each one before running it.
Loading voting…