Skip to content

← Public intelligence

npm package

@budibase/worker

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8npmAmendedPublished

    Budibase: Builder-to-Admin Privilege Escalation via onboardUsers Endpoint Without SMTP Configuration

    CVE-2026-45716 · GHSA-c54j-xp92-wh28

    Affected
    • npm @budibase/worker < 3.38.1
    Fixed in
    3.38.1· Vendor fix available
    Issue
    The POST /api/global/users/onboard endpoint is protected by workspaceBuilderOrAdmin middleware, allowing any user with builder permissions to access it. When SMTP email is not configured (the default for self-hosted Budibase instances), this endpoint bypasses the admin-restricted invite flow and directly creates users via bulkCreate, accepting arbitrary admin and builder role assignments from the request body. A builder-level user can create a new global admin account and receive the generated password in the response, achieving full privilege escalation. Details The vulnerability stems from a mismatch between the authorization level of the onboardUsers endpoint and the user-creation capabilities it exposes when SMTP is not configured. Route definition (packages/worker/src/api/routes/global/users.ts:93-109): Compare with the invite and inviteMultiple endpoints which are correctly admin-only: Controller (packages/worker/src/api/controllers/global/users.ts:601-630): Middleware…

    Recommended action: Upgrade to 3.38.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.7npmAmendedPublished

    Budibase Improper Control of Dynamically-Managed Code Resources vulnerability

    CVE-2022-3225 · GHSA-x92g-49gh-63qm

    Affected
    • npm @budibase/worker < 1.3.20
    Fixed in
    1.3.20· Vendor fix available
    Issue
    Improper Control of Dynamically-Managed Code Resources in GitHub repository budibase/budibase prior to 1.3.20.

    Recommended action: Upgrade to 1.3.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →