Budibase: Builder-to-Admin Privilege Escalation via onboardUsers Endpoint Without SMTP Configuration
CVE-2026-45716GHSA-c54j-xp92-wh28
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/worker 3.38.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @budibase/worker
- Affected
- < 3.38.1
- Fixed in
- 3.38.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c54j-xp92-wh28 lists affected ranges: npm @budibase/worker >=0 <3.38.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c54j-xp92-wh28 lists affected ranges: npm @budibase/worker >=0 <3.38.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-45716: 0.26% estimated exploitation activity in the next 30 days; percentile 17.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The POST /api/global/users/onboard endpoint is protected by workspaceBuilderOrAdmin middleware, allowing any user with builder permissions to access it. When SMTP email is not configured (the default for self-hosted Budibase instances), this endpoint bypasses the admin-restricted invite flow and directly creates users via bulkCreate, accepting arbitrary admin and builder role assignments from the request body. A builder-level user can create a new global admin account and receive the generated password in the response, achieving full privilege escalation. Details The vulnerability stems from a mismatch between the authorization level of the onboardUsers endpoint and the user-creation capabilities it exposes when SMTP is not configured. Route definition (packages/worker/src/api/routes/global/users.ts:93-109): Compare with the invite and inviteMultiple endpoints which are correctly admin-only: Controller (packages/worker/src/api/controllers/global/users.ts:601-630): Middleware…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c54j-xp92-wh28
- Revision 1 · created ·
Published from osv record GHSA-c54j-xp92-wh28
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45716 Advisory: Budibase: Builder-to-Admin Privilege Escalation via onboardUsers Endpoint Without SMTP Configuration IDs: CVE-2026-45716, GHSA-c54j-xp92-wh28 Record: https://patchnext.com/advisories/cve-2026-45716 (revision 2, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @budibase/worker 3.38.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @budibase/worker: affected < 3.38.1; fixed in 3.38.1 ## Suggested inspection (read-only) - `npm ls @budibase/worker --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @budibase/worker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c54j-xp92-wh28 (OSV record GHSA-c54j-xp92-wh28 lists affected ranges: npm @budibase/worker >=0 <3.38.1 (fixed)) - Verified: https://github.com/advisories/GHSA-c54j-xp92-wh28 (GitHub-reviewed advisory GHSA-c54j-xp92-wh28 lists affected ranges: npm @budibase/worker >=0 <3.38.1) Commands are suggestions: review each one before running it.
Loading voting…