Low, CVSS 3.7npmAmendedPublished
@better-auth/drizzle-adapter: Concurrent requests can exceed rate limits on PostgreSQL
CVE-2026-110861 · GHSA-44jh-23m7-hpcf
- Affected
- npm @better-auth/drizzle-adapter >= 1.6.17, < 1.7.7
- Fixed in
- 1.7.7· Vendor fix available
- Issue
- Am I affected? You are affected if you use `@better-auth/drizzle-adapter` from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or `@better-auth/kysely-adapter` 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database. All of these must be true: - Rate limiting is enabled. - Rate-limit records are stored in the database. - The database is PostgreSQL, used through one of the adapter versions above. You are not affected if you store rate-limit records in memory (the default) or in secondary storage. Summary Database-backed rate limiting on PostgreSQL can let a burst of concurrent requests go over the configured maximum. When many requests arrive at the same time, several of them can pass the limit check together. This weakens the rate limit on password sign-in, two-factor verification, one-time codes, password resets, and other rate-limited endpoints. Impact An attacker who sends many requests at once can make…
Recommended action: Upgrade to 1.7.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.