Skip to content

← Actionable
Low, CVSS 3.7amended

@better-auth/drizzle-adapter: Concurrent requests can exceed rate limits on PostgreSQL

CVE-2026-110861GHSA-44jh-23m7-hpcf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.7.7; @better-auth/kysely-adapter 1.7.0; @better-auth/drizzle-adapter 1.7.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-110861: 0.22% estimated exploitation activity in the next 30 days; percentile 12.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? You are affected if you use `@better-auth/drizzle-adapter` from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or `@better-auth/kysely-adapter` 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database. All of these must be true: - Rate limiting is enabled. - Rate-limit records are stored in the database. - The database is PostgreSQL, used through one of the adapter versions above. You are not affected if you store rate-limit records in memory (the default) or in secondary storage.

Summary Database-backed rate limiting on PostgreSQL can let a burst of concurrent requests go over the configured maximum. When many requests arrive at the same time, several of them can pass the limit check together. This weakens the rate limit on password sign-in, two-factor verification, one-time codes, password resets, and other rate-limited endpoints.

Impact An attacker who sends many requests at once can make…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-44jh-23m7-hpcf

  2. Revision 1 · created ·

    Published from ghsa record GHSA-44jh-23m7-hpcf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-110861

Advisory: @better-auth/drizzle-adapter: Concurrent requests can exceed rate limits on PostgreSQL
IDs: CVE-2026-110861, GHSA-44jh-23m7-hpcf
Record: https://patchnext.com/advisories/ghsa-44jh-23m7-hpcf (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.7.7; @better-auth/kysely-adapter 1.7.0; @better-auth/drizzle-adapter 1.7.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected >= 1.6.17, < 1.7.7; fixed in 1.7.7
- npm @better-auth/kysely-adapter: affected >= 1.6.17, < 1.7.0; fixed in 1.7.0
- npm @better-auth/drizzle-adapter: affected >= 1.6.17, < 1.7.7; fixed in 1.7.7

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @better-auth/kysely-adapter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @better-auth/drizzle-adapter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth, @better-auth/kysely-adapter, @better-auth/drizzle-adapter.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-44jh-23m7-hpcf (GitHub-reviewed advisory GHSA-44jh-23m7-hpcf lists affected ranges: npm @better-auth/drizzle-adapter >=1.6.17 =1.6.17 =1.6.17 <1.7.7)
- Verified: https://osv.dev/vulnerability/GHSA-44jh-23m7-hpcf (OSV record GHSA-44jh-23m7-hpcf lists affected ranges: npm @better-auth/drizzle-adapter >=1.6.17 =1.6.17 =1.6.17 <1.7.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…