Skip to content

← Public intelligence

npm package

@backstage/plugin-proxy-backend

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8npmAmendedPublished

    Backstage: Inconsistent credential enforcement for overlapping proxy routes

    CVE-2026-106456 · GHSA-472h-9c5j-prrr

    Affected
    • npm @backstage/plugin-proxy-backend >= 0.5.0, < 0.6.18
    Fixed in
    0.6.18· Vendor fix available
    Issue
    Impact An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. Exploitation requires this specific overlapping route configuration. The resulting confidentiality and integrity impact depends on the capabilities exposed by the nested upstream. Patches Upgrade @backstage/plugin-proxy-backend to version 0.6.18 or later. The fixed package is available in Backstage v1.55.0. Workarounds - Avoid nesting a credential-protected proxy path below a path configured with dangerously-allow-unauthenticated. - Apply the same credential requirement to overlapping proxy paths. - Restrict direct network access to the Backstage backend until the patched…

    Recommended action: Upgrade to 0.6.18 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  2. Medium, CVSS 6.4npmAmendedPublished

    Backstage: Improper input validation in proxy-backend

    CVE-2026-106491 · GHSA-9ghw-48h5-v2w5

    Affected
    • npm @backstage/plugin-proxy-backend < 0.6.17
    Fixed in
    0.6.17· Vendor fix available
    Issue
    Impact An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. Patches Patched in @backstage/plugin-proxy-backend version 0.6.17 Workarounds - Deploy a reverse proxy or WAF in front of Backstage that normalizes request paths before they reach the backend.

    Recommended action: Upgrade to 0.6.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →