Skip to content

← Actionable
Medium, CVSS 4.8amended

Backstage: Inconsistent credential enforcement for overlapping proxy routes

CVE-2026-106456GHSA-472h-9c5j-prrr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-proxy-backend 0.6.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-106456: 0.24% estimated exploitation activity in the next 30 days; percentile 15.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. Exploitation requires this specific overlapping route configuration. The resulting confidentiality and integrity impact depends on the capabilities exposed by the nested upstream. Patches Upgrade @backstage/plugin-proxy-backend to version 0.6.18 or later. The fixed package is available in Backstage v1.55.0. Workarounds - Avoid nesting a credential-protected proxy path below a path configured with dangerously-allow-unauthenticated. - Apply the same credential requirement to overlapping proxy paths. - Restrict direct network access to the Backstage backend until the patched…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-472h-9c5j-prrr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-472h-9c5j-prrr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-472h-9c5j-prrr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-106456

Advisory: Backstage: Inconsistent credential enforcement for overlapping proxy routes
IDs: CVE-2026-106456, GHSA-472h-9c5j-prrr
Record: https://patchnext.com/advisories/cve-2026-106456 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-proxy-backend 0.6.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-proxy-backend: affected >= 0.5.0, < 0.6.18; fixed in 0.6.18

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-proxy-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-proxy-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-472h-9c5j-prrr (GitHub-reviewed advisory GHSA-472h-9c5j-prrr lists affected ranges: npm @backstage/plugin-proxy-backend >=0.5.0 <0.6.18)
- Verified: https://osv.dev/vulnerability/GHSA-472h-9c5j-prrr (OSV record GHSA-472h-9c5j-prrr lists affected ranges: npm @backstage/plugin-proxy-backend >=0.5.0 <0.6.18 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…