Skip to content

← Public intelligence

npm package

@apollo/composition

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Apollo Federation has Improper Enforcement of Access Control on Transitive Fields

    GHSA-m8jr-fxqx-8xx6

    Affected
    • npm @apollo/composition < 2.9.5; >= 2.10.0-alpha.3, < 2.10.4; >= 2.11.0-preview.1, < 2.11.5; >= 2.12.0-preview.0, < 2.12.1
    Fixed in
    2.9.52.11.52.10.42.12.1· Vendor fix available
    Issue
    A vulnerability in Apollo Federation's composition logic did not enforce that fields depending on protected data through @requires and/or @fromContext directives have the same access control requirements as the fields they reference. This allowed queries to access protected fields indirectly through their dependencies, bypassing access control checks. A fix to composition logic in Federation now enforces that dependent fields match the access control requirements from of the fields they reference. Details Apollo Federation allows users to specify @authenticated, @requiresScopes, and @policy directives to protect fields at the field level. The @requires directive allows a field to depend on data from other fields in the schema, and @fromContext allows a field to use values from the execution context. However, Apollo Router does not enforce access control requirements on these transitively-accessed fields, and Apollo Federation did not require that fields using @requires or…

    Recommended action: Upgrade to 2.12.1, 2.11.5, 2.10.4 or 2.9.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    @apollo/composition has Improper Enforcement of Access Control on Interface Types and Fields

    CVE-2025-64530 · GHSA-mx7m-j9xf-62hw

    Affected
    • npm @apollo/composition < 2.9.5; >= 2.10.0-alpha.3, < 2.10.4; >= 2.11.0-preview.1, < 2.11.5; >= 2.12.0-preview.1, < 2.12.1
    Fixed in
    2.9.52.11.52.10.42.12.1· Vendor fix available
    Issue
    A vulnerability in Apollo Federation's composition logic allowed some queries to Apollo Router to improperly bypass access controls on types/fields. Apollo Federation incorrectly allowed user-defined access control directives on interface types/fields, which could be bypassed by instead querying the implementing object types/fields in Apollo Router via inline or named fragments. A fix to composition logic in Federation now disallows interfaces types and fields to contain user-defined access control directives. Details Apollo Federation allows users to specify access control directives (@authenticated, @requiresScopes, and @policy) to protect object and interface types and fields. However, the GraphQL specification does not define inheritance rules for directives from interfaces to their implementations. When querying object or interface types/fields, Apollo Router will enforce any directives on those object or interface types/fields, but ignore any directives on interface…

    Recommended action: Upgrade to 2.12.1, 2.11.5, 2.10.4 or 2.9.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →