Skip to content

← Actionable
High, CVSS 7.5amended

Apollo Federation has Improper Enforcement of Access Control on Transitive Fields

GHSA-m8jr-fxqx-8xx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apollo/composition 2.12.1, 2.11.5, 2.10.4, 2.9.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @apollo/composition

    Affected
    < 2.9.5>= 2.10.0-alpha.3, < 2.10.4>= 2.11.0-preview.1, < 2.11.5>= 2.12.0-preview.0, < 2.12.1
    Fixed in
    2.9.5, 2.11.5, 2.10.4, 2.12.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability in Apollo Federation's composition logic did not enforce that fields depending on protected data through @requires and/or @fromContext directives have the same access control requirements as the fields they reference. This allowed queries to access protected fields indirectly through their dependencies, bypassing access control checks. A fix to composition logic in Federation now enforces that dependent fields match the access control requirements from of the fields they reference. Details Apollo Federation allows users to specify @authenticated, @requiresScopes, and @policy directives to protect fields at the field level. The @requires directive allows a field to depend on data from other fields in the schema, and @fromContext allows a field to use values from the execution context. However, Apollo Router does not enforce access control requirements on these transitively-accessed fields, and Apollo Federation did not require that fields using @requires or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m8jr-fxqx-8xx6

  2. Revision 1 · created ·

    Published from osv record GHSA-m8jr-fxqx-8xx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-m8jr-fxqx-8xx6

Advisory: Apollo Federation has Improper Enforcement of Access Control on Transitive Fields
IDs: GHSA-m8jr-fxqx-8xx6
Record: https://patchnext.com/advisories/ghsa-m8jr-fxqx-8xx6 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apollo/composition 2.12.1, 2.11.5, 2.10.4, 2.9.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apollo/composition: affected < 2.9.5; >= 2.10.0-alpha.3, < 2.10.4; >= 2.11.0-preview.1, < 2.11.5; >= 2.12.0-preview.0, < 2.12.1; fixed in 2.9.5, 2.11.5, 2.10.4, 2.12.1

## Suggested inspection (read-only)
- `npm ls @apollo/composition --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apollo/composition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m8jr-fxqx-8xx6 (OSV record GHSA-m8jr-fxqx-8xx6 lists affected ranges: npm @apollo/composition >=0 =2.10.0-alpha.3 =2.11.0-preview.1 =2.12.0-preview.0 <2.12.1 (fixed))
- Verified: https://github.com/advisories/GHSA-m8jr-fxqx-8xx6 (GitHub-reviewed advisory GHSA-m8jr-fxqx-8xx6 lists affected ranges: npm @apollo/composition >=0 =2.10.0-alpha.3 =2.11.0-preview.1 =2.12.0-preview.0 <2.12.1)

Commands are suggestions: review each one before running it.

Loading voting…