Low, CVSS 2.1npmAmendedPublished
@ai-sdk/provider-utils has an Uncontrolled Resource Consumption issue
CVE-2026-8769 · GHSA-866g-f22w-33x8
- Affected
- npm @ai-sdk/provider-utils < 3.0.28; >= 4.0.0-beta.10, < 4.0.33; >= 5.0.0-beta.0, < 5.0.1
- Fixed in
- 4.0.333.0.285.0.1· Vendor fix available
- Issue
- Versions of @ai-sdk/provider-utils before 3.0.28, from 4.0.0 before 4.0.33, and from 5.0.0 before 5.0.1 are vulnerable to uncontrolled resource consumption. The createJsonResponseHandler, createJsonErrorResponseHandler, and createStatusCodeErrorResponseHandler functions in packages/provider-utils/src/response-handler.ts read response bodies without a shared size limit, allowing a remote attacker with low privileges to cause excessive memory consumption. The exploit has been publicly disclosed and may be utilized.
Recommended action: Upgrade to 5.0.1, 4.0.33 or 3.0.28 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.