@ai-sdk/provider-utils has an Uncontrolled Resource Consumption issue
CVE-2026-8769GHSA-866g-f22w-33x8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@ai-sdk/provider-utils 5.0.1, 4.0.33, 3.0.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.0.28>= 4.0.0-beta.10, < 4.0.33>= 5.0.0-beta.0, < 5.0.1
- Fixed in
- 4.0.33, 3.0.28, 5.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-866g-f22w-33x8 lists affected ranges: npm @ai-sdk/provider-utils >=0 =4.0.0-beta.10 =5.0.0-beta.0 <5.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-866g-f22w-33x8 lists affected ranges: npm @ai-sdk/provider-utils >=0 =4.0.0-beta.10 =5.0.0-beta.0 <5.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-8769: 0.56% estimated exploitation activity in the next 30 days; percentile 46.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of @ai-sdk/provider-utils before 3.0.28, from 4.0.0 before 4.0.33, and from 5.0.0 before 5.0.1 are vulnerable to uncontrolled resource consumption. The createJsonResponseHandler, createJsonErrorResponseHandler, and createStatusCodeErrorResponseHandler functions in packages/provider-utils/src/response-handler.ts read response bodies without a shared size limit, allowing a remote attacker with low privileges to cause excessive memory consumption. The exploit has been publicly disclosed and may be utilized.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-866g-f22w-33x8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-866g-f22w-33x8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-8769 Advisory: @ai-sdk/provider-utils has an Uncontrolled Resource Consumption issue IDs: CVE-2026-8769, GHSA-866g-f22w-33x8 Record: https://patchnext.com/advisories/cve-2026-8769 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @ai-sdk/provider-utils 5.0.1, 4.0.33, 3.0.28. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @ai-sdk/provider-utils: affected < 3.0.28; >= 4.0.0-beta.10, < 4.0.33; >= 5.0.0-beta.0, < 5.0.1; fixed in 4.0.33, 3.0.28, 5.0.1 ## Suggested inspection (read-only) - `npm ls @ai-sdk/provider-utils --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @ai-sdk/provider-utils. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-866g-f22w-33x8 (OSV record GHSA-866g-f22w-33x8 lists affected ranges: npm @ai-sdk/provider-utils >=0 =4.0.0-beta.10 =5.0.0-beta.0 <5.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-866g-f22w-33x8 (GitHub-reviewed advisory GHSA-866g-f22w-33x8 lists affected ranges: npm @ai-sdk/provider-utils >=0 =4.0.0-beta.10 =5.0.0-beta.0 <5.0.1) Commands are suggestions: review each one before running it.
Loading voting…