Medium, CVSS 5.3npmAmendedPublished
ag-grid packages vulnerable to Prototype Pollution
CVE-2024-39001 · GHSA-328p-362g-r48j
- Affected
- npm @ag-grid-enterprise/charts >= 32.0.0, <= 32.0.0; < 31.3.4
- Fixed in
- 31.3.432.0.1· Vendor fix available
- Issue
- ag-grid-enterprise v31.3.2 was discovered to contain a prototype pollution via the component ModuleSupport.jsonApply. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Recommended action: Upgrade to 32.0.1 or 31.3.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.