Skip to content

← Actionable
Medium, CVSS 5.3amended

ag-grid packages vulnerable to Prototype Pollution

CVE-2024-39001GHSA-328p-362g-r48j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@ag-grid-enterprise/charts 32.0.1, 31.3.4; ag-grid-community 32.0.1, 31.3.4; ag-grid-enterprise 32.0.1, 31.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-39001: 0.83% estimated exploitation activity in the next 30 days; percentile 57.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ag-grid-enterprise v31.3.2 was discovered to contain a prototype pollution via the component ModuleSupport.jsonApply. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-328p-362g-r48j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-328p-362g-r48j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-39001

Advisory: ag-grid packages vulnerable to Prototype Pollution
IDs: CVE-2024-39001, GHSA-328p-362g-r48j
Record: https://patchnext.com/advisories/cve-2024-39001 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @ag-grid-enterprise/charts 32.0.1, 31.3.4; ag-grid-community 32.0.1, 31.3.4; ag-grid-enterprise 32.0.1, 31.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @ag-grid-enterprise/charts: affected >= 32.0.0, <= 32.0.0; < 31.3.4; fixed in 31.3.4, 32.0.1
- npm ag-grid-community: affected >= 32.0.0, <= 32.0.0; < 31.3.4; fixed in 31.3.4, 32.0.1
- npm ag-grid-enterprise: affected >= 32.0.0, <= 32.0.0; < 31.3.4; fixed in 31.3.4, 32.0.1

## Suggested inspection (read-only)
- `npm ls @ag-grid-enterprise/charts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls ag-grid-community --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls ag-grid-enterprise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @ag-grid-enterprise/charts, ag-grid-community, ag-grid-enterprise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-328p-362g-r48j (OSV record GHSA-328p-362g-r48j lists affected ranges: npm @ag-grid-enterprise/charts >=32.0.0 =0 =32.0.0 =0 =32.0.0 =0 <31.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-328p-362g-r48j (GitHub-reviewed advisory GHSA-328p-362g-r48j lists affected ranges: npm @ag-grid-enterprise/charts >=32.0.0 =0 =32.0.0 =0 =32.0.0 =0 <31.3.4)

Commands are suggestions: review each one before running it.

Loading voting…