BIP-322 address ownership verification bypass for P2WPKH and P2SH-P2WPKH addresses
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bip322 0.0.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io bip322
- Affected
- >= 0.0.6, < 0.0.11
- Fixed in
- 0.0.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0334 lists affected ranges: crates.io bip322 >=0.0.6 <0.0.11 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Affected versions of `bip322` accepted a BIP-322 proof created with an attacker-controlled private key as a valid signature for an unrelated victim P2WPKH or P2SH-P2WPKH address, allowing complete authentication bypass in applications using `verify_simple`, `verify_simple_encoded`, `verify_full`, or `verify_full_encoded` as proof that a user controls a Bitcoin address. In `verify_full`, the verifier obtained the public key from the caller-controlled witness and passed it to `verify_full_p2wpkh`, where the supposed public-key mismatch check read the key from the same witness and compared it with itself: ```rust let witness_pub_key = &witness.to_vec()[1]; if &pub_key.to_bytes() != witness_pub_key { return Err(Error::PublicKeyMismatch); } ``` Since `pub_key` was originally parsed from that exact witness element, this comparison was tautological. The code verified that the signature was valid for the public key embedded in the witness, but never verified that this public key hashes to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record RUSTSEC-2026-0334
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5chw-87w3-j9cv Advisory: BIP-322 address ownership verification bypass for P2WPKH and P2SH-P2WPKH addresses IDs: GHSA-5chw-87w3-j9cv Record: https://patchnext.com/advisories/rustsec-2026-0334 (revision 1, source checked 23 Oct 2026, 22:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bip322 0.0.11. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io bip322: affected >= 0.0.6, < 0.0.11; fixed in 0.0.11 ## Suggested inspection (read-only) - crates.io bip322: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bip322. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0334 (OSV record RUSTSEC-2026-0334 lists affected ranges: crates.io bip322 >=0.0.6 <0.0.11 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…