Zebra v4.4.0 still accepts V5 SIGHASH_SINGLE without a corresponding output
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zebra-script 6.0.1; zebrad 4.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io zebra-script
- Affected
- < 6.0.1
- Fixed in
- 6.0.1
crates.io zebrad
- Affected
- < 4.4.1
- Fixed in
- 4.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pvmv-cwg8-v6c8 lists affected ranges: crates.io zebrad >=0 =0 <6.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Consensus Divergence in V5 Transparent SIGHASHSINGLE With No Corresponding Output Summary Zebra failed to enforce a ZIP-244 consensus rule for V5 transparent transactions: when an input is signed with SIGHASHSINGLE and there is no transparent output at the same index as that input, validation must fail. Zebra instead asked the underlying sighash library to compute a digest, and that library produced a digest over an empty output set rather than failing. An attacker could craft a V5 transaction with more transparent inputs than outputs that Zebra accepts but zcashd rejects, creating a consensus split between Zebra and zcashd nodes. A previous fix (GHSA-cwfq-rfcr-8hmp) addressed a closely related case in the same area of the code, but did not cover this specific one. Severity Critical - This is a Consensus Vulnerability that could allow a malicious party to induce network partitioning, service disruption, and potential double-spend attacks against affected nodes. Note that the impact…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pvmv-cwg8-v6c8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pvmv-cwg8-v6c8 Advisory: Zebra v4.4.0 still accepts V5 SIGHASH_SINGLE without a corresponding output IDs: GHSA-pvmv-cwg8-v6c8 Record: https://patchnext.com/advisories/ghsa-pvmv-cwg8-v6c8 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zebra-script 6.0.1; zebrad 4.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io zebra-script: affected < 6.0.1; fixed in 6.0.1 - crates.io zebrad: affected < 4.4.1; fixed in 4.4.1 ## Suggested inspection (read-only) - crates.io zebra-script: check the installed version with your package manager. - crates.io zebrad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zebra-script, zebrad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pvmv-cwg8-v6c8 (GitHub-reviewed advisory GHSA-pvmv-cwg8-v6c8 lists affected ranges: crates.io zebrad >=0 =0 <6.0.1) Commands are suggestions: review each one before running it.
Loading voting…