Thelia BackOffice default template vulnerable to Cross-site Scripting
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (thelia/backoffice-default-template 2.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist thelia/backoffice-default-template
- Affected
- >= 2.1.0, < 2.1.2
- Fixed in
- 2.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pp7v-wxx9-hm6r lists affected ranges: Packagist thelia/backoffice-default-template >=2.1.0 <2.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The BackOffice of Thelia (error.html template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pp7v-wxx9-hm6r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pp7v-wxx9-hm6r Advisory: Thelia BackOffice default template vulnerable to Cross-site Scripting IDs: GHSA-pp7v-wxx9-hm6r Record: https://patchnext.com/advisories/ghsa-pp7v-wxx9-hm6r (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: thelia/backoffice-default-template 2.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist thelia/backoffice-default-template: affected >= 2.1.0, < 2.1.2; fixed in 2.1.2 ## Suggested inspection (read-only) - Packagist thelia/backoffice-default-template: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on thelia/backoffice-default-template. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pp7v-wxx9-hm6r (GitHub-reviewed advisory GHSA-pp7v-wxx9-hm6r lists affected ranges: Packagist thelia/backoffice-default-template >=2.1.0 <2.1.2) Commands are suggestions: review each one before running it.
Loading voting…