Skip to content

← Actionable
High, CVSS 7.7amended

Flowise is vulnerable to arbitrary file exposure through its ReadFileTool

GHSA-j44m-5v8f-gc9c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.0.8; flowise 3.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The ReadFileTool in Flowise does not restrict file path access, allowing authenticated attackers to exploit this vulnerability to read arbitrary files from the file system, potentially leading to remote command execution. Details Flowise supports providing ReadFileTool for large models to read files in the server's file system. The implementation of this tool is located at packages/components/nodes/tools/ReadFile/ReadFile.ts. The tool directly uses the filepath parameter passed to it without verifying whether the path belongs to Flowise's working directory. Authenticated attackers can exploit this vulnerability to read any known file on the server. For example, if the victim deploys in a Docker environment, the attacker could attempt to read sensitive files such as /root/.flowise/encryption.key, /root/.flowise/database.sqlite, and obtain sensitive information. If the victim does not use a Docker environment for deployment, the attacker could try reading sensitive files like…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j44m-5v8f-gc9c

  2. Revision 1 · created ·

    Published from osv record GHSA-j44m-5v8f-gc9c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-j44m-5v8f-gc9c

Advisory: Flowise is vulnerable to arbitrary file exposure through its ReadFileTool
IDs: GHSA-j44m-5v8f-gc9c
Record: https://patchnext.com/advisories/ghsa-j44m-5v8f-gc9c (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.0.8; flowise 3.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-components: affected < 3.0.8; fixed in 3.0.8
- npm flowise: affected < 3.0.8; fixed in 3.0.8

## Suggested inspection (read-only)
- `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-components, flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j44m-5v8f-gc9c (OSV record GHSA-j44m-5v8f-gc9c lists affected ranges: npm flowise >=0 =0 <3.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-j44m-5v8f-gc9c (GitHub-reviewed advisory GHSA-j44m-5v8f-gc9c lists affected ranges: npm flowise >=0 =0 <3.0.8)

Commands are suggestions: review each one before running it.

Loading voting…