Skip to content

← Actionable
Low, CVSS 1.3

Schema.org has cross-site scripting (XSS) via script break-out in toScript() output

GHSA-hwmc-r6mf-jh83

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (spatie/schema-org 4.0.2, 3.23.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist spatie/schema-org

    Affected
    >= 3.23.1, < 3.23.2>= 4.0.0, < 4.0.2
    Fixed in
    3.23.2, 4.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Schema.org has a cross-site scripting (XSS) vulnerability via script break-out in toScript() output.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hwmc-r6mf-jh83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-hwmc-r6mf-jh83

Advisory: Schema.org has cross-site scripting (XSS) via script break-out in toScript() output
IDs: GHSA-hwmc-r6mf-jh83
Record: https://patchnext.com/advisories/ghsa-hwmc-r6mf-jh83 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: spatie/schema-org 4.0.2, 3.23.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist spatie/schema-org: affected >= 3.23.1, < 3.23.2; >= 4.0.0, < 4.0.2; fixed in 3.23.2, 4.0.2

## Suggested inspection (read-only)
- Packagist spatie/schema-org: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on spatie/schema-org.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hwmc-r6mf-jh83 (GitHub-reviewed advisory GHSA-hwmc-r6mf-jh83 lists affected ranges: Packagist spatie/schema-org >=3.23.1 =4.0.0 <4.0.2)

Commands are suggestions: review each one before running it.

Loading voting…