Keycloak vulnerable to authorization bypass via incorrect uri comparison
CVE-2026-9800GHSA-f5p5-6xmx-p252
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-services 26.6.4; org.keycloak:keycloak-policy-enforcer 26.0.10; keycloak 26.7.0, 26.4.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.keycloak:keycloak-services
- Affected
- < 26.6.4
- Fixed in
- 26.6.4
Maven org.keycloak:keycloak-policy-enforcer
- Affected
- < 26.0.10
- Fixed in
- 26.0.10
Bitnami keycloak
- Affected
- >= 26.4.0, < 26.4.13>= 26.6.0, < 26.7.0
- Fixed in
- 26.7.0, 26.4.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5p5-6xmx-p252 lists affected ranges: Maven org.keycloak:keycloak-services >=0 =0 <26.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f5p5-6xmx-p252 lists affected ranges: Maven org.keycloak:keycloak-services >=0 =0 <26.0.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-keycloak-2026-9800 lists affected ranges: Bitnami keycloak >=26.4.0 =26.6.0 <26.7.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-9800: 0.65% estimated exploitation activity in the next 30 days; percentile 51.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description A flaw was found in Keycloak Policy Enforcer. This vulnerability allows any authenticated user to bypass all authorization policies, including role, scope, and User-Managed Access (UMA) permission checks. By including the configured access-denied page path within a request URL, either as a path segment or a query parameter, an attacker can gain unauthorized access to protected resources.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record BIT-keycloak-2026-9800
- Revision 2 · amended ·
Amended from osv record GHSA-f5p5-6xmx-p252
- Revision 1 · created ·
Published from ghsa record GHSA-f5p5-6xmx-p252
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9800 Advisory: Keycloak vulnerable to authorization bypass via incorrect uri comparison IDs: CVE-2026-9800, GHSA-f5p5-6xmx-p252 Record: https://patchnext.com/advisories/cve-2026-9800 (revision 3, source checked 30 Oct 2026, 07:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-services 26.6.4; org.keycloak:keycloak-policy-enforcer 26.0.10; keycloak 26.7.0, 26.4.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.keycloak:keycloak-services: affected < 26.6.4; fixed in 26.6.4 - Maven org.keycloak:keycloak-policy-enforcer: affected < 26.0.10; fixed in 26.0.10 - Bitnami keycloak: affected >= 26.4.0, < 26.4.13; >= 26.6.0, < 26.7.0; fixed in 26.7.0, 26.4.13 ## Suggested inspection (read-only) - Maven org.keycloak:keycloak-services: check the installed version with your package manager. - Maven org.keycloak:keycloak-policy-enforcer: check the installed version with your package manager. - Bitnami keycloak: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.keycloak:keycloak-services, org.keycloak:keycloak-policy-enforcer, keycloak. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f5p5-6xmx-p252 (GitHub-reviewed advisory GHSA-f5p5-6xmx-p252 lists affected ranges: Maven org.keycloak:keycloak-services >=0 =0 <26.0.10) - Verified: https://osv.dev/vulnerability/GHSA-f5p5-6xmx-p252 (OSV record GHSA-f5p5-6xmx-p252 lists affected ranges: Maven org.keycloak:keycloak-services >=0 =0 <26.0.10 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-keycloak-2026-9800 (OSV record BIT-keycloak-2026-9800 lists affected ranges: Bitnami keycloak >=26.4.0 =26.6.0 <26.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…