Keycloak Generates an Error Message Containing Sensitive Information
CVE-2026-9794GHSA-fqjh-8322-vgrv
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.keycloak:keycloak-services
- Affected
- <= 26.4.7>= 26.5.0, < 26.6.3
- Fixed in
- 26.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fqjh-8322-vgrv lists affected ranges: Maven org.keycloak:keycloak-services >=0 =26.5.0 <26.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-9794: 0.44% estimated exploitation activity in the next 30 days; percentile 37.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in Keycloak. A remote, unauthenticated attacker can exploit this vulnerability by sending specially crafted SOAP requests to the SAML ECP (Security Assertion Markup Language Enhanced Client or Proxy) endpoint with varying client IDs. By observing distinct faultstrings in the responses, the attacker can determine the client's protocol type, leading to information disclosure.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fqjh-8322-vgrv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9794 Advisory: Keycloak Generates an Error Message Containing Sensitive Information IDs: CVE-2026-9794, GHSA-fqjh-8322-vgrv Record: https://patchnext.com/advisories/cve-2026-9794 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.keycloak:keycloak-services 26.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.keycloak:keycloak-services: affected <= 26.4.7; >= 26.5.0, < 26.6.3; fixed in 26.6.3 ## Suggested inspection (read-only) - Maven org.keycloak:keycloak-services: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.keycloak:keycloak-services. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fqjh-8322-vgrv (GitHub-reviewed advisory GHSA-fqjh-8322-vgrv lists affected ranges: Maven org.keycloak:keycloak-services >=0 =26.5.0 <26.6.3) Commands are suggestions: review each one before running it.
Loading voting…