Skip to content

← Actionable
Critical, CVSS 9.5amended

Flowise: Pyodide validator Unicode homoglyph bypass leads to RCE

CVE-2026-70470GHSA-52fh-8v99-63c2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.3; flowise 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.5 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-70470: 0.97% estimated exploitation activity in the next 30 days; percentile 62.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The validatePythonCodeForDataFrame blacklist in packages/components/src/pythonCodeValidator.ts can be bypassed with Unicode homoglyph identifiers, allowing arbitrary Python execution inside Pyodide and full OS command execution on the Flowise host via Pyodide's js module interop. This reopens the RCE paths patched as GHSA-3hjv-c53m-58jj (CSV Agent) and GHSA-v38x-c887-992f (Airtable Agent). Details packages/components/src/pythonCodeValidator.ts gates every call to pyodide.runPythonAsync in packages/components/nodes/agents/CSVAgent/CSVAgent.ts (lines 147, 198) and packages/components/nodes/agents/AirtableAgent/AirtableAgent.ts (line 186). The gate is a regex blacklist: Two design flaws combine into a bypass: 1. JavaScript regex \b is ASCII-only. Word boundaries are computed against the ASCII word class [A-Za-z0-9]. A Unicode letter such as U+1D41A (mathematical bold small a) is treated as a non-word character, so \bclass\b never matches cl𝐚ss. 2. Python 3 (PEP 3131)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-52fh-8v99-63c2

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-52fh-8v99-63c2

  4. Revision 1 · created ·

    Published from ghsa record GHSA-52fh-8v99-63c2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-70470

Advisory: Flowise: Pyodide validator Unicode homoglyph bypass leads to RCE
IDs: CVE-2026-70470, GHSA-52fh-8v99-63c2
Record: https://patchnext.com/advisories/cve-2026-70470 (revision 4, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.3; flowise 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-components: affected <= 3.1.2; fixed in 3.1.3
- npm flowise: affected <= 3.1.2; fixed in 3.1.3

## Suggested inspection (read-only)
- `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-components, flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-52fh-8v99-63c2 (GitHub-reviewed advisory GHSA-52fh-8v99-63c2 lists affected ranges: npm flowise >=0 =0 <=3.1.2)
- Verified: https://osv.dev/vulnerability/GHSA-52fh-8v99-63c2 (OSV record GHSA-52fh-8v99-63c2 lists affected ranges: npm flowise >=0 =0 <3.1.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…