Flowise RCE via SQLite Record Manager Node
CVE-2026-69259GHSA-x3hf-7cj6-3r4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.3; flowise 3.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 3.1.2
- Fixed in
- 3.1.3
npm flowise
- Affected
- <= 3.1.2
- Fixed in
- 3.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x3hf-7cj6-3r4m lists affected ranges: npm flowise >=0 =0 <=3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x3hf-7cj6-3r4m lists affected ranges: npm flowise >=0 =0 <3.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-69259: 0.82% estimated exploitation activity in the next 30 days; percentile 57.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
============================================================================= Security Advisory elttam Topic: Flowise RCE via SQLite Record Manager Node Module: FlowiseAI/Flowise Disclosed: 24-Apr-2026 Credits: Alex Brown Affects: FlowiseAI/Flowise 3.1.2 I. Background Flowise AI is an open-source, low-code platform for building AI applications—such as chatbots, workflows, and autonomous agents—through an intuitive drag-and-drop interface, minimising the need for extensive coding. Flowise allows users to connect to a local SQLite database for record management of Upsert Vector Store operations. II. Problem Description The database path for the "SQLite Record Manager" node could be overridden using the additionalConfig input, as demonstrated in the following code snippet. https://github.com/FlowiseAI/Flowise/blob/flowise-components@3.1.2/packages/components/nodes/recordmanager/SQLiteRecordManager/SQLiteRecordManager.ts <1 The additionalConfig input was user controllable. <2 The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-x3hf-7cj6-3r4m
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-x3hf-7cj6-3r4m
- Revision 1 · created ·
Published from ghsa record GHSA-x3hf-7cj6-3r4m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69259 Advisory: Flowise RCE via SQLite Record Manager Node IDs: CVE-2026-69259, GHSA-x3hf-7cj6-3r4m Record: https://patchnext.com/advisories/cve-2026-69259 (revision 4, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.3; flowise 3.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise-components: affected <= 3.1.2; fixed in 3.1.3 - npm flowise: affected <= 3.1.2; fixed in 3.1.3 ## Suggested inspection (read-only) - `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise-components, flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x3hf-7cj6-3r4m (GitHub-reviewed advisory GHSA-x3hf-7cj6-3r4m lists affected ranges: npm flowise >=0 =0 <=3.1.2) - Verified: https://osv.dev/vulnerability/GHSA-x3hf-7cj6-3r4m (OSV record GHSA-x3hf-7cj6-3r4m lists affected ranges: npm flowise >=0 =0 <3.1.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…