Skip to content

← Actionable
Critical, CVSS 9.4amended

Flowise: Remote Code Execution Vulnerability in CSVAgent

CVE-2026-69256GHSA-x6vm-w76m-8j7g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.3; flowise 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-69256: 1.01% estimated exploitation activity in the next 30 days; percentile 63.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The CSVAgent node was observed to allow users to write Python code which gets executed via pyodide. The original intent was to allow users to utilise the pandas library for CSV processing. Although there is a denylist that checks for dangerous Python constructs from being passed in, pandas has a readpickle() function that deserialises a pickled payload and this can be leveraged to achieve code execution. Details The affected file is the CSVAgent node, found in: flowise-components/nodes/agents/CSVAgent/CSVAgent.ts. At <1, the customReadCSVFunc is supplied by the user. This input goes through input validation that denies dangerous Python constructs from being passed in: However, by using pandas.readpickle(), an attacker can achieve code execution without hitting any of the denied words. PoC First, generate a pickled payload that performs an OS command (replace the IP and port with your listening IP and port): Run it and note the encoded payload to be used later: 1. In the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-x6vm-w76m-8j7g

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-x6vm-w76m-8j7g

  4. Revision 1 · created ·

    Published from ghsa record GHSA-x6vm-w76m-8j7g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-69256

Advisory: Flowise: Remote Code Execution Vulnerability in CSVAgent
IDs: CVE-2026-69256, GHSA-x6vm-w76m-8j7g
Record: https://patchnext.com/advisories/cve-2026-69256 (revision 4, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.3; flowise 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-components: affected <= 3.1.2; fixed in 3.1.3
- npm flowise: affected <= 3.1.2; fixed in 3.1.3

## Suggested inspection (read-only)
- `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-components, flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x6vm-w76m-8j7g (GitHub-reviewed advisory GHSA-x6vm-w76m-8j7g lists affected ranges: npm flowise-components >=0 =0 <=3.1.2)
- Verified: https://osv.dev/vulnerability/GHSA-x6vm-w76m-8j7g (OSV record GHSA-x6vm-w76m-8j7g lists affected ranges: npm flowise-components >=0 =0 <3.1.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…