Flowise: CSV Agent Remote Code Execution via Pyodide Code Injection — Root Shell Verified
CVE-2026-69255GHSA-vmv7-4m6c-3cg5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.3; flowise 3.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 3.1.2
- Fixed in
- 3.1.3
npm flowise
- Affected
- <= 3.1.2
- Fixed in
- 3.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vmv7-4m6c-3cg5 lists affected ranges: npm flowise >=0 =0 <=3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vmv7-4m6c-3cg5 lists affected ranges: npm flowise >=0 =0 <3.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-69255: 0.60% estimated exploitation activity in the next 30 days; percentile 48.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
UPDATE 2026-05-20: Full RCE as root VERIFIED This is not theoretical — a Meterpreter reverse shell session as root has been established on Flowise 3.1.2. Verified Exploit Chain 1. Python code injection via base64string = "${base64String}" (CSVAgent.ts line 161) 2. Pyodide js bridge provides access to the host Node.js process 3. process.mainModule.constructor.load('childprocess') loads childprocess (bypasses ESM require restriction) 4. .execSync('CMD') executes arbitrary OS commands as root (PID 1 in container) Working RCE Payload Constraint: No commas allowed in payload — csvFile.split(',') splits on all commas. Metasploit Session Proof Additional Verified Impact Credential Theft: Arbitrary File Read via process.binding('fs').readFileUtf8('/etc/hostname') → cbce3fb352b7 Server DoS — certain native binding calls (spawnsync) crash the Node.js process entirely. CVSS v3.1: 9.9 CRITICAL AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H --- Original Report (below) Vulnerable Code File:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-vmv7-4m6c-3cg5
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-vmv7-4m6c-3cg5
- Revision 1 · created ·
Published from ghsa record GHSA-vmv7-4m6c-3cg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69255 Advisory: Flowise: CSV Agent Remote Code Execution via Pyodide Code Injection — Root Shell Verified IDs: CVE-2026-69255, GHSA-vmv7-4m6c-3cg5 Record: https://patchnext.com/advisories/cve-2026-69255 (revision 4, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.3; flowise 3.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise-components: affected <= 3.1.2; fixed in 3.1.3 - npm flowise: affected <= 3.1.2; fixed in 3.1.3 ## Suggested inspection (read-only) - `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise-components, flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vmv7-4m6c-3cg5 (GitHub-reviewed advisory GHSA-vmv7-4m6c-3cg5 lists affected ranges: npm flowise >=0 =0 <=3.1.2) - Verified: https://osv.dev/vulnerability/GHSA-vmv7-4m6c-3cg5 (OSV record GHSA-vmv7-4m6c-3cg5 lists affected ranges: npm flowise >=0 =0 <3.1.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…