Flowise: RCE via NodeVM Sandbox Escape in executeJavaScriptCode() nodeVMOptions Override
CVE-2026-69254GHSA-3769-jgqc-cxm7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.3; flowise 3.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 3.1.2
- Fixed in
- 3.1.3
npm flowise
- Affected
- <= 3.1.2
- Fixed in
- 3.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3769-jgqc-cxm7 lists affected ranges: npm flowise >=0 =0 <=3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3769-jgqc-cxm7 lists affected ranges: npm flowise >=0 =0 <3.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-69254: 0.69% estimated exploitation activity in the next 30 days; percentile 52.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A sandbox escape vulnerability in executeJavaScriptCode() allows any authenticated user to execute arbitrary system commands as root on the Flowise server. The function accepts caller-provided nodeVMOptions that override the default sandbox security settings via JavaScript's spread operator, allowing an attacker to re-enable blocked modules like childprocess and fs. Details The vulnerability is in packages/components/src/utils.ts at line 1755: The spread operator allows any caller to override require.builtin with [""], which permits all Node.js built-in modules including childprocess. Taint 01: Route Registration packages/server/src/routes/node-custom-functions/index.ts (line 8) Taint 02: Controller executeCustomFunction() passes req.body to service — packages/server/src/controllers/nodes/index.ts (line 90) Taint 03: Service executeCustomNodeFunction() loads the customFunction node and calls init() with user-provided javascriptFunction —…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-3769-jgqc-cxm7
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-3769-jgqc-cxm7
- Revision 1 · created ·
Published from ghsa record GHSA-3769-jgqc-cxm7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-69254 Advisory: Flowise: RCE via NodeVM Sandbox Escape in executeJavaScriptCode() nodeVMOptions Override IDs: CVE-2026-69254, GHSA-3769-jgqc-cxm7 Record: https://patchnext.com/advisories/cve-2026-69254 (revision 4, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.3; flowise 3.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise-components: affected <= 3.1.2; fixed in 3.1.3 - npm flowise: affected <= 3.1.2; fixed in 3.1.3 ## Suggested inspection (read-only) - `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise-components, flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3769-jgqc-cxm7 (GitHub-reviewed advisory GHSA-3769-jgqc-cxm7 lists affected ranges: npm flowise >=0 =0 <=3.1.2) - Verified: https://osv.dev/vulnerability/GHSA-3769-jgqc-cxm7 (OSV record GHSA-3769-jgqc-cxm7 lists affected ranges: npm flowise >=0 =0 <3.1.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…