Sylius Mollie Plugin has unauthenticated IDOR that leaks order token and customer PII
CVE-2026-68501GHSA-x83g-979r-f5fh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/mollie-plugin 3.3.1, 3.2.4, 2.2.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/mollie-plugin
- Affected
- < 2.2.8>= 3.0.0, < 3.2.4>= 3.3.0, < 3.3.1
- Fixed in
- 2.2.8, 3.2.4, 3.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x83g-979r-f5fh lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x83g-979r-f5fh lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- EPSS
- CVE-2026-68501: 0.87% estimated exploitation activity in the next 30 days; percentile 58.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Two unauthenticated Mollie shop endpoints look up orders by a sequential integer orderId with no ownership or session check. Chained, they expose customer PII. GET /{locale}/thank-you (PageRedirectController::thankYouAction, route syliusmollieshopthankyoupageredirect) loads the order with findOneBy(['id' = $orderId]) and returns a 302 whose Location header carries that order's tokenValue. Any orderId thus yields that order's token. A non-existent id dereferences null and returns a 500. The handler also writes the raw orderId into the session. GET /{locale}/get-code (QrCodeAction::fetchQrCodeFromOrder, route syliusmollieshopgetqrcode) runs the same lookup and returns the order's QR code and id as JSON, ignoring the session cart; this is where the front-end got the integer id. A bad id 500s here too. That tokenValue is the order's only access control. Passed to the Sylius core page GET /{locale}/register-after-checkout/{tokenValue} it returns a form pre-filled with the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x83g-979r-f5fh
- Revision 1 · created ·
Published from osv record GHSA-x83g-979r-f5fh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-68501 Advisory: Sylius Mollie Plugin has unauthenticated IDOR that leaks order token and customer PII IDs: CVE-2026-68501, GHSA-x83g-979r-f5fh Record: https://patchnext.com/advisories/cve-2026-68501 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/mollie-plugin 3.3.1, 3.2.4, 2.2.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/mollie-plugin: affected < 2.2.8; >= 3.0.0, < 3.2.4; >= 3.3.0, < 3.3.1; fixed in 2.2.8, 3.2.4, 3.3.1 ## Suggested inspection (read-only) - Packagist sylius/mollie-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/mollie-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x83g-979r-f5fh (OSV record GHSA-x83g-979r-f5fh lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-x83g-979r-f5fh (GitHub-reviewed advisory GHSA-x83g-979r-f5fh lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1) Commands are suggestions: review each one before running it.
Loading voting…