Sylius Mollie Plugin vulnerable to payment status forgery via the payment webhook
CVE-2026-68500GHSA-rc52-c4hv-w89p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/mollie-plugin 3.3.1, 3.2.4, 2.2.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/mollie-plugin
- Affected
- < 2.2.8>= 3.0.0, < 3.2.4>= 3.3.0, < 3.3.1
- Fixed in
- 2.2.8, 3.2.4, 3.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rc52-c4hv-w89p lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rc52-c4hv-w89p lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-68500: 0.68% estimated exploitation activity in the next 30 days; percentile 52.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The shop payment webhook POST /{locale}/update-payment (route syliusmollieshoppaymentwebhook) accepts two independent, attacker-controlled parameters: id (the Mollie payment ID, verified against Mollie's API) and orderId (the Sylius order ID, read directly from the database). The handler never verifies that the Mollie payment belongs to the referenced order. An unauthenticated attacker who holds any valid paid Mollie payment ID, for example from a EUR 1 order they placed themselves, can submit it together with any victim orderId. The victim's order payment is then transitioned to completed (or any other Mollie-derived state) without any funds being transferred for that order. Sylius order IDs are sequential integers, and the endpoint requires no authentication, CSRF token or rate limiting, so the attack scales trivially across all pending orders.
Patches Fixed in versions 2.2.8, 3.2.4 and 3.3.1. The webhook now binds the payment to the order: it reads the Mollie payment ID…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rc52-c4hv-w89p
- Revision 1 · created ·
Published from osv record GHSA-rc52-c4hv-w89p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-68500 Advisory: Sylius Mollie Plugin vulnerable to payment status forgery via the payment webhook IDs: CVE-2026-68500, GHSA-rc52-c4hv-w89p Record: https://patchnext.com/advisories/cve-2026-68500 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/mollie-plugin 3.3.1, 3.2.4, 2.2.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/mollie-plugin: affected < 2.2.8; >= 3.0.0, < 3.2.4; >= 3.3.0, < 3.3.1; fixed in 2.2.8, 3.2.4, 3.3.1 ## Suggested inspection (read-only) - Packagist sylius/mollie-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/mollie-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rc52-c4hv-w89p (OSV record GHSA-rc52-c4hv-w89p lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rc52-c4hv-w89p (GitHub-reviewed advisory GHSA-rc52-c4hv-w89p lists affected ranges: Packagist sylius/mollie-plugin >=0 =3.0.0 =3.3.0 <3.3.1) Commands are suggestions: review each one before running it.
Loading voting…