borg extract might modify out-of-tree files when extracting maliciously crafted archives
CVE-2026-62268GHSA-gfp8-w835-v44j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (borgbackup 2.0.0b22, 1.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI borgbackup
- Affected
- < 1.4.5>= 2.0.0b1, < 2.0.0b22
- Fixed in
- 1.4.5, 2.0.0b22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gfp8-w835-v44j lists affected ranges: PyPI borgbackup >=0 =2.0.0b1 <2.0.0b22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gfp8-w835-v44j lists affected ranges: PyPI borgbackup >=0 =2.0.0b1 <2.0.0b22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A maliciously crafted archive could contain a symlink (e.g. "evil" - "/etc") followed by an item below it ("evil/passwd"), or an item whose path embeds ".." (e.g. "a/../../etc/passwd"). When extracting such items, borg followed the symlink / resolved the "..", so it could delete or overwrite files outside the extraction directory. In a quite similar scenario, a crafted archive could contain a slave hardlink item with the hardlink source pointing outside the extraction directory. When extracting such an item, borg would hard-link the outside and the inside item. Note: that sounds bad, but it is no big issue in practice: to create such a malicious archive, the attacker would need repository access and (for encrypted or authenticated repos) also the borg key and passphrase. Affected: likely all borg releases before 1.4.5 (and also all borg 2.0.0 betas before b22). Patches - 1.4.x release series: fix released with 1.4.5. commits 3e9ed6d1ad6d3531b39c07b8ef3ecf41fce4437f and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-gfp8-w835-v44j
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-gfp8-w835-v44j
- Revision 1 · created ·
Published from ghsa record GHSA-gfp8-w835-v44j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-62268 Advisory: borg extract might modify out-of-tree files when extracting maliciously crafted archives IDs: CVE-2026-62268, GHSA-gfp8-w835-v44j Record: https://patchnext.com/advisories/cve-2026-62268 (revision 4, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: borgbackup 2.0.0b22, 1.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI borgbackup: affected < 1.4.5; >= 2.0.0b1, < 2.0.0b22; fixed in 1.4.5, 2.0.0b22 ## Suggested inspection (read-only) - `python -m pip show borgbackup`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on borgbackup. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gfp8-w835-v44j (GitHub-reviewed advisory GHSA-gfp8-w835-v44j lists affected ranges: PyPI borgbackup >=0 =2.0.0b1 <2.0.0b22) - Verified: https://osv.dev/vulnerability/GHSA-gfp8-w835-v44j (OSV record GHSA-gfp8-w835-v44j lists affected ranges: PyPI borgbackup >=0 =2.0.0b1 <2.0.0b22 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…