Apache ActiveMQ, Apache ActiveMQ Web Console vulnerable to Cross-site Scripting
CVE-2026-52760GHSA-j548-68g5-9j7x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-web-console 6.2.7, 5.19.8; org.apache.activemq:apache-activemq 6.2.7, 5.19.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-web-console
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Maven org.apache.activemq:apache-activemq
- Affected
- < 5.19.8>= 6.0.0, < 6.2.7
- Fixed in
- 5.19.8, 6.2.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j548-68g5-9j7x lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 =0 =6.0.0 <6.2.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web Console. The browse page in the web console renders a message Id directly without sanitization. This allows an authenticated producer to send a message with a JMS message ID that has been crafted to contain HTML/JavaScript such that when an administrator browses the queue in the Web Console, the payload executes in their browser. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Web Console: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j548-68g5-9j7x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52760 Advisory: Apache ActiveMQ, Apache ActiveMQ Web Console vulnerable to Cross-site Scripting IDs: CVE-2026-52760, GHSA-j548-68g5-9j7x Record: https://patchnext.com/advisories/cve-2026-52760 (revision 1, source checked 5 Nov 2026, 18:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-web-console 6.2.7, 5.19.8; org.apache.activemq:apache-activemq 6.2.7, 5.19.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-web-console: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 - Maven org.apache.activemq:apache-activemq: affected < 5.19.8; >= 6.0.0, < 6.2.7; fixed in 5.19.8, 6.2.7 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-web-console: check the installed version with your package manager. - Maven org.apache.activemq:apache-activemq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-web-console, org.apache.activemq:apache-activemq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j548-68g5-9j7x (GitHub-reviewed advisory GHSA-j548-68g5-9j7x lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 =0 =6.0.0 <6.2.7) Commands are suggestions: review each one before running it.
Loading voting…