Skip to content

← Public intelligence

Maven package

org.apache.activemq:activemq-web-console

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Apache ActiveMQ Sensitive Information Disclosure via the Jetty ResourceHandler

    CVE-2010-1587 · GHSA-v2c9-9m8v-8jjm

    Affected
    • Maven org.apache.activemq:activemq-web-console >= 5.0.0, < 5.3.2
    Fixed in
    5.3.2· Vendor fix available
    Issue
    The Jetty ResourceHandler in Apache ActiveMQ 5.x before 5.3.2 and 5.4.x before 5.4.0 allows remote attackers to read JSP source code via a // (slash slash) initial substring in a URI for (1) admin/index.jsp, (2) admin/queues.jsp, or (3) admin/topics.jsp.

    Recommended action: Upgrade to 5.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1MavenPublished

    Apache ActiveMQ webconsole admin GUI is open to XSS

    CVE-2020-1941 · GHSA-cc94-3v9c-7rm8

    Affected
    • Maven org.apache.activemq:activemq-web-console >= 5.0.0, < 5.15.12
    Fixed in
    5.15.12· Vendor fix available
    Issue
    In Apache ActiveMQ 5.0.0 to 5.15.11, the webconsole admin GUI is open to XSS, in the view that lists the contents of a queue.

    Recommended action: Upgrade to 5.15.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1MavenPublished

    Apache ActiveMQ web console vulnerable to Cross-site Scripting

    CVE-2018-8006 · GHSA-hvwm-2624-rp9x

    Affected
    • Maven org.apache.activemq:activemq-web-console >= 5.0.0, < 5.15.6
    Fixed in
    5.15.6· Vendor fix available
    Issue
    An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the queue.jsp page of Apache ActiveMQ versions 5.0.0 to 5.15.5. The root cause of this issue is improper data filtering of the QueueFilter parameter.

    Recommended action: Upgrade to 5.15.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →