zebrad has consensus divergence via P2SH sigop undercount in pure-Rust disabled-opcode parser
CVE-2026-52735GHSA-gf9r-m956-97qx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zebra-script 7.0.0; zebrad 4.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io zebra-script
- Affected
- <= 6.0.1
- Fixed in
- 7.0.0
crates.io zebrad
- Affected
- <= 4.4.1
- Fixed in
- 4.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gf9r-m956-97qx lists affected ranges: crates.io zebra-script >=0 =0 <=4.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:H · score source
- EPSS
- CVE-2026-52735: 0.51% estimated exploitation activity in the next 30 days; percentile 43.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected You are affected if: 1. You run any version of zebrad up to and including v4.4.1. 2. Your node validates blocks on mainnet, testnet, or any network where both Zebra and zcashd nodes participate. All default configurations are affected. No feature flags, non-default settings, or special build options are required. Summary Zebra's P2SH sigop counter uses a pure-Rust code path that short-circuits on disabled opcodes (such as OPCODESEPARATOR), returning a partial count of zero for any sigops following the disabled opcode. The reference implementation (zcashd) correctly counts through disabled opcodes in its static sigop analysis. This produces a consensus divergence: Zebra accepts blocks that zcashd rejects when the block-wide MAXBLOCKSIGOPS = 20,000 threshold is crossed on one side but not the other. An attacker can exploit this without mining capability. Broadcasting transactions that spend P2SH outputs with malicious redeem scripts is sufficient; any Zebra miner who…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gf9r-m956-97qx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52735 Advisory: zebrad has consensus divergence via P2SH sigop undercount in pure-Rust disabled-opcode parser IDs: CVE-2026-52735, GHSA-gf9r-m956-97qx Record: https://patchnext.com/advisories/cve-2026-52735 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zebra-script 7.0.0; zebrad 4.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io zebra-script: affected <= 6.0.1; fixed in 7.0.0 - crates.io zebrad: affected <= 4.4.1; fixed in 4.5.0 ## Suggested inspection (read-only) - crates.io zebra-script: check the installed version with your package manager. - crates.io zebrad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zebra-script, zebrad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gf9r-m956-97qx (GitHub-reviewed advisory GHSA-gf9r-m956-97qx lists affected ranges: crates.io zebra-script >=0 =0 <=4.4.1) Commands are suggestions: review each one before running it.
Loading voting…