Skip to content

← Actionable
High, CVSS 8.6amended

Fedify has an incomplete SSRF mitigation after GHSA-p9cg-vqcc-grcx: validatePublicUrl allows special-use IPv4 ranges

CVE-2026-50131GHSA-xw9q-2mv6-9fr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fedify/fedify 2.2.4, 2.1.15, 2.0.19, 1.10.11, 1.9.12; @fedify/vocab-runtime 2.2.4, 2.1.15, 2.0.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @fedify/fedify

    Affected
    >= 0.11.2, < 1.9.12>= 1.10.0, < 1.10.11>= 2.0.0, < 2.0.19>= 2.1.0, < 2.1.15>= 2.2.0, < 2.2.4
    Fixed in
    2.2.4, 1.10.11, 1.9.12, 2.1.15, 2.0.19
  • npm @fedify/vocab-runtime

    Affected
    < 2.0.19>= 2.1.0, < 2.1.15>= 2.2.0, < 2.2.4
    Fixed in
    2.2.4, 2.1.15, 2.0.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-50131: 0.35% estimated exploitation activity in the next 30 days; percentile 28.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Fedify previously addressed SSRF/internal network access in GHSA-p9cg-vqcc-grcx by adding public URL validation before runtime document and media fetching. However, the current IPv4 validation logic appears incomplete. The validatePublicUrl() protection relies on isValidPublicIPv4Address() to reject non-public IPv4 destinations. The function blocks common private and local ranges such as 10.0.0.0/8, 127.0.0.0/8, 169.254.0.0/16, 172.16.0.0/12, and 192.168.0.0/16, but it still treats several special-use, reserved, multicast, benchmarking, and carrier-grade NAT IPv4 ranges as valid public destinations. Because this validation is used as an SSRF defense before outbound fetches, this appears to be an incomplete mitigation or bypass class for the previous SSRF issue. I tested this against the current repository code at unreleased version 2.3.0. I used =0.11.2, <=2.2.3 as the suspected affected range because 0.11.2 is listed as a patched version for GHSA-p9cg-vqcc-grcx, and this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xw9q-2mv6-9fr8

  2. Revision 1 · created ·

    Published from osv record GHSA-xw9q-2mv6-9fr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-50131

Advisory: Fedify has an incomplete SSRF mitigation after GHSA-p9cg-vqcc-grcx: validatePublicUrl allows special-use IPv4 ranges
IDs: CVE-2026-50131, GHSA-xw9q-2mv6-9fr8
Record: https://patchnext.com/advisories/cve-2026-50131 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fedify/fedify 2.2.4, 2.1.15, 2.0.19, 1.10.11, 1.9.12; @fedify/vocab-runtime 2.2.4, 2.1.15, 2.0.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fedify/fedify: affected >= 0.11.2, < 1.9.12; >= 1.10.0, < 1.10.11; >= 2.0.0, < 2.0.19; >= 2.1.0, < 2.1.15; >= 2.2.0, < 2.2.4; fixed in 2.2.4, 1.10.11, 1.9.12, 2.1.15, 2.0.19
- npm @fedify/vocab-runtime: affected < 2.0.19; >= 2.1.0, < 2.1.15; >= 2.2.0, < 2.2.4; fixed in 2.2.4, 2.1.15, 2.0.19

## Suggested inspection (read-only)
- `npm ls @fedify/fedify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @fedify/vocab-runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fedify/fedify, @fedify/vocab-runtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xw9q-2mv6-9fr8 (OSV record GHSA-xw9q-2mv6-9fr8 lists affected ranges: npm @fedify/fedify >=0.11.2 =1.10.0 =2.0.0 =2.1.0 =2.2.0 =0 =2.1.0 =2.2.0 <2.2.4 (fixed))
- Verified: https://github.com/advisories/GHSA-xw9q-2mv6-9fr8 (GitHub-reviewed advisory GHSA-xw9q-2mv6-9fr8 lists affected ranges: npm @fedify/fedify >=0.11.2 =1.10.0 =2.0.0 =2.1.0 =2.2.0 =0 =2.1.0 =2.2.0 <2.2.4)

Commands are suggestions: review each one before running it.

Loading voting…