Skip to content

← Actionable
High, CVSS 7.4amended

auth-fetch-mcp has SSRF Protection Bypass via IPv4-mapped IPv6 Loopback

CVE-2026-49857GHSA-pvrj-8cg3-j5f8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth-fetch-mcp 3.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-49857: 0.49% estimated exploitation activity in the next 30 days; percentile 42.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SSRF Protection Bypass via IPv4-mapped IPv6 Loopback Summary auth-fetch-mcp v3.0.1 implements SSRF protection in assertSafeUrl() (src/security.ts) to block requests to private and loopback addresses. However, the isPrivateV6() function fails to detect IPv4-mapped IPv6 loopback addresses in their hex-normalized form. When an attacker supplies a URL such as http://[::ffff:127.0.0.1]:PORT/, the Node.js WHATWG URL parser silently normalizes the host to [::ffff:7f00:1]. Because net.isIPv4('7f00:1') returns false, the private-IP check is bypassed and the URL is passed to the browser or HTTP client, allowing the MCP tool to reach loopback services that are supposed to be blocked. The issue is exploitable under default configuration without any special environment variable and carries a CVSS v3.1 Base Score of 7.4 (High). Details The vulnerable function is isPrivateV6() in src/security.ts, called from assertSafeUrl() which gates every outbound request made by the authfetch and downloadmedia…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pvrj-8cg3-j5f8

  2. Revision 1 · created ·

    Published from osv record GHSA-pvrj-8cg3-j5f8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-49857

Advisory: auth-fetch-mcp has SSRF Protection Bypass via IPv4-mapped IPv6 Loopback
IDs: CVE-2026-49857, GHSA-pvrj-8cg3-j5f8
Record: https://patchnext.com/advisories/cve-2026-49857 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth-fetch-mcp 3.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth-fetch-mcp: affected <= 3.0.1; fixed in 3.0.2

## Suggested inspection (read-only)
- `npm ls auth-fetch-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth-fetch-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pvrj-8cg3-j5f8 (OSV record GHSA-pvrj-8cg3-j5f8 lists affected ranges: npm auth-fetch-mcp >=0 <3.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-pvrj-8cg3-j5f8 (GitHub-reviewed advisory GHSA-pvrj-8cg3-j5f8 lists affected ranges: npm auth-fetch-mcp >=0 <=3.0.1)

Commands are suggestions: review each one before running it.

Loading voting…