Sigstore Java has a vulnerability with bundle verification of integratedTime
CVE-2026-48791GHSA-qqw8-7c2r-jxch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dev.sigstore:sigstore-java 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven dev.sigstore:sigstore-java
- Affected
- >= 2.0.0, <= 2.0.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qqw8-7c2r-jxch lists affected ranges: Maven dev.sigstore:sigstore-java >=2.0.0 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.0 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-48791: 0.07% estimated exploitation activity in the next 30 days; percentile 0.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Regression: Verification of integratedTime from Rekor V1 Log Entry against Fuclio Certificate validity was missing Details - PR #1008 erroneously removed verification of the integrated (Rekor entry) time) against the Fulcio certificate. - PR #1185 re-added this verification with enhancements that adhere to the Sigstore verification spec. - old sigstore-conformance test for this check was built incorrectly PoC A new bundle was added to sigstore-conformance to test this: sigstore-java:2.0.0 can be tested against it and shown to be unexpectedly passing Verify this bundle against a.txt Impact This vulnerability impacts only users verifying bundles with dev.sigstore:sigstore-java:2.0.0. Older versions are not affected, it is fixed in dev.sigstore:sigstore-java:2.1.0 A malicious actor may exploit this if they were able to access a users system and exfiltrate the temporary private key used during signing and then reuse an old fulcio certificate later without requiring direct access…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qqw8-7c2r-jxch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48791 Advisory: Sigstore Java has a vulnerability with bundle verification of integratedTime IDs: CVE-2026-48791, GHSA-qqw8-7c2r-jxch Record: https://patchnext.com/advisories/cve-2026-48791 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dev.sigstore:sigstore-java 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven dev.sigstore:sigstore-java: affected >= 2.0.0, <= 2.0.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Maven dev.sigstore:sigstore-java: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dev.sigstore:sigstore-java. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qqw8-7c2r-jxch (GitHub-reviewed advisory GHSA-qqw8-7c2r-jxch lists affected ranges: Maven dev.sigstore:sigstore-java >=2.0.0 <=2.0.0) Commands are suggestions: review each one before running it.
Loading voting…