ouroboros-ai Vulnerable to Remote Code Execution via Untrusted Project-Directory .env
CVE-2026-47211GHSA-c4m7-2gwp-vw76
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ouroboros-ai 0.39.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ouroboros-ai
- Affected
- < 0.39.0
- Fixed in
- 0.39.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c4m7-2gwp-vw76 lists affected ranges: PyPI ouroboros-ai >=0 <0.39.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c4m7-2gwp-vw76 lists affected ranges: PyPI ouroboros-ai >=0 <0.39.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47211: 0.19% estimated exploitation activity in the next 30 days; percentile 8.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Remote Code Execution (RCE) vulnerability was discovered in Ouroboros. If a user clones a malicious repository and runs Ouroboros commands within that directory, it can lead to arbitrary code execution and potential system takeover. The vulnerability (CWE-426: Untrusted Search Path & CWE-15: External Control of System Setting) stems from Ouroboros loading the .env file from the current working directory. Prior to the patch, execution-affecting environment variables such as OUROBOROSCLIPATH, OPENCODECLIPATH, and other backend selectors were accepted directly from this local .env. An attacker could include a malicious script in the repository and point the CLI path variable to it (e.g., OUROBOROSCLIPATH=./maliciousscript.sh). When the user executes a command like ouroboros init or any command that instantiates the adapter, the malicious script is executed instead of the intended CLI. Patches The vulnerability has been patched in version 0.39.0 via PR #1078. The fix establishes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c4m7-2gwp-vw76
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c4m7-2gwp-vw76
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47211 Advisory: ouroboros-ai Vulnerable to Remote Code Execution via Untrusted Project-Directory .env IDs: CVE-2026-47211, GHSA-c4m7-2gwp-vw76 Record: https://patchnext.com/advisories/cve-2026-47211 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ouroboros-ai 0.39.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ouroboros-ai: affected < 0.39.0; fixed in 0.39.0 ## Suggested inspection (read-only) - `python -m pip show ouroboros-ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ouroboros-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c4m7-2gwp-vw76 (OSV record GHSA-c4m7-2gwp-vw76 lists affected ranges: PyPI ouroboros-ai >=0 <0.39.0 (fixed)) - Verified: https://github.com/advisories/GHSA-c4m7-2gwp-vw76 (GitHub-reviewed advisory GHSA-c4m7-2gwp-vw76 lists affected ranges: PyPI ouroboros-ai >=0 <0.39.0) Commands are suggestions: review each one before running it.
Loading voting…