Omni: Reader-level users can retrieve imported cluster CA keys via ResourceService
CVE-2026-45726GHSA-wv8c-6mx2-xf4j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/siderolabs/omni 1.7.3, 1.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.3.0, < 1.6.6>= 1.7.0, < 1.7.3
- Fixed in
- 1.6.6, 1.7.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wv8c-6mx2-xf4j lists affected ranges: Go github.com/siderolabs/omni >=1.3.0 =1.7.0 <1.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:A/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-45726: 0.14% estimated exploitation activity in the next 30 days; percentile 3.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Omni supports importing standalone Talos clusters. During this process, an ImportedClusterSecrets resource is created, which contains the full CA secrets bundle for the cluster being imported. If these secrets are not rotated by the importing actor, an authenticated Omni user with Reader access can read this resource and gain full access to the Talos, Kubernetes and etcd APIs of the cluster. Severity - Attack Vector: Adjacent: the attacker needs to be in the same network to be able to access Talos/Kubernetes APIs with the compromised keys. - Attack Complexity: High: the attacker needs a deep understanding of Omni's internals. The resource is only created for imported clusters, and is normally not represented to users via any high-level API. - Privileges Required: Low: the role Reader is sufficient for the attacker to be able to read an imported cluster's secrets. - User Interaction: Required: another user must have imported a cluster to Omni for this vulnerability to exist. -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wv8c-6mx2-xf4j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45726 Advisory: Omni: Reader-level users can retrieve imported cluster CA keys via ResourceService IDs: CVE-2026-45726, GHSA-wv8c-6mx2-xf4j Record: https://patchnext.com/advisories/cve-2026-45726 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/siderolabs/omni 1.7.3, 1.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/siderolabs/omni: affected >= 1.3.0, < 1.6.6; >= 1.7.0, < 1.7.3; fixed in 1.6.6, 1.7.3 ## Suggested inspection (read-only) - Go github.com/siderolabs/omni: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/siderolabs/omni. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wv8c-6mx2-xf4j (GitHub-reviewed advisory GHSA-wv8c-6mx2-xf4j lists affected ranges: Go github.com/siderolabs/omni >=1.3.0 =1.7.0 <1.7.3) Commands are suggestions: review each one before running it.
Loading voting…