Omni has a TOCTOU race condition that allows multiple concurrent uses of a single-use SAML session token
CVE-2026-45720GHSA-5x9f-6vg5-qg4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/siderolabs/omni 1.7.3, 1.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.6.6>= 1.7.0, < 1.7.3
- Fixed in
- 1.6.6, 1.7.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5x9f-6vg5-qg4m lists affected ranges: Go github.com/siderolabs/omni >=0 =1.7.0 <1.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-45720: 0.14% estimated exploitation activity in the next 30 days; percentile 3.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary SAML.getSession (internal/pkg/auth/interceptor/saml.go) checks the Used flag on a SAMLAssertion resource and then marks it used in two separate state operations. Because the check and the update are not atomic, concurrent requests carrying the same saml-session token can both observe Used == false, both pass validation, and both return a successful authentication context. An attacker who obtains a valid saml-session token can exploit this window to authenticate as the token's owner multiple times, defeating the one-time-use guarantee. Severity - Attack Vector: Local: the attacker needs to either be able to intercept the local, unencrypted traffic or needs access to user's browser. - Attack Complexity: High: the attacker must first obtain a valid saml-session token belonging to the victim (requires a separate interception step; the token is ephemeral and single-use by design). - Privileges Required: None: no Omni account is required to carry out the race once the session token…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5x9f-6vg5-qg4m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45720 Advisory: Omni has a TOCTOU race condition that allows multiple concurrent uses of a single-use SAML session token IDs: CVE-2026-45720, GHSA-5x9f-6vg5-qg4m Record: https://patchnext.com/advisories/cve-2026-45720 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/siderolabs/omni 1.7.3, 1.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/siderolabs/omni: affected < 1.6.6; >= 1.7.0, < 1.7.3; fixed in 1.6.6, 1.7.3 ## Suggested inspection (read-only) - Go github.com/siderolabs/omni: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/siderolabs/omni. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5x9f-6vg5-qg4m (GitHub-reviewed advisory GHSA-5x9f-6vg5-qg4m lists affected ranges: Go github.com/siderolabs/omni >=0 =1.7.0 <1.7.3) Commands are suggestions: review each one before running it.
Loading voting…