Skip to content

← Actionable
High, CVSS 7.2amended

OpenCTI: Privilege escalation via graphQL API is abusable by organization admins, due to incorrect ACL on userEdit relationAdd

CVE-2026-44730GHSA-q537-qhj4-wcjx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pycti 6.9.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pycti

    Affected
    < 6.9.7
    Fixed in
    6.9.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-44730: 0.32% estimated exploitation activity in the next 30 days; percentile 24.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An organization admin can escalate their privileges by adding a user from a different organization with higher privileges, to their own organization. Impact Full platform access, access to sensitive or proprietary information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q537-qhj4-wcjx

  2. Revision 1 · created ·

    Published from osv record GHSA-q537-qhj4-wcjx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44730

Advisory: OpenCTI: Privilege escalation via graphQL API is abusable by organization admins, due to incorrect ACL on userEdit relationAdd
IDs: CVE-2026-44730, GHSA-q537-qhj4-wcjx
Record: https://patchnext.com/advisories/cve-2026-44730 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pycti 6.9.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pycti: affected < 6.9.7; fixed in 6.9.7

## Suggested inspection (read-only)
- `python -m pip show pycti`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pycti.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q537-qhj4-wcjx (OSV record GHSA-q537-qhj4-wcjx lists affected ranges: PyPI pycti >=0 <6.9.7 (fixed))
- Verified: https://github.com/advisories/GHSA-q537-qhj4-wcjx (GitHub-reviewed advisory GHSA-q537-qhj4-wcjx lists affected ranges: PyPI pycti >=0 <6.9.7)

Commands are suggestions: review each one before running it.

Loading voting…