Skip to content

← Actionable
Critical, CVSS 9.3

Zebra has Consensus Divergence in Transparent Sighash Hash-Type Handling due to Stale Buffer

CVE-2026-44497GHSA-gq4h-3grw-2rhv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zebra-script 6.0.0; zebrad 4.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io zebra-script

    Affected
    <= 5.0.1
    Fixed in
    6.0.0
  • crates.io zebrad

    Affected
    < 4.4.0
    Fixed in
    4.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H · score source
EPSS
  • CVE-2026-44497: 0.19% estimated exploitation activity in the next 30 days; percentile 8.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CVE-2026-44497: Consensus Divergence in Transparent Sighash Hash-Type Handling due to Stale Buffer Summary The fix for https://github.com/ZcashFoundation/zebra/security/advisories/GHSA-8m29-fpq5-89jj introduced a separate issue due to insuficient error handling of the case where the sighash type is invalid, during sighash computation. Instead of returning an error, the normal flow would resume, and the input sighash buffer would be left untouched. In scenarios where a previous signature validation could leave a valid sighash in the buffer, an invalid hash-type could be incorrectly accepted, which would create a consensus split between Zebra and zcashd nodes. Severity Critical - This is a Consensus Vulnerability that could allow a malicious party to induce network partitioning, service disruption, and potential double-spend attacks against affected nodes. Note that the impact is currently alleviated by the fact that currently most miners run zcashd. Affected Versions Zebra 4.3.1.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gq4h-3grw-2rhv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-44497

Advisory: Zebra has Consensus Divergence in Transparent Sighash Hash-Type Handling due to Stale Buffer
IDs: CVE-2026-44497, GHSA-gq4h-3grw-2rhv
Record: https://patchnext.com/advisories/cve-2026-44497 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zebra-script 6.0.0; zebrad 4.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io zebra-script: affected <= 5.0.1; fixed in 6.0.0
- crates.io zebrad: affected < 4.4.0; fixed in 4.4.0

## Suggested inspection (read-only)
- crates.io zebra-script: check the installed version with your package manager.
- crates.io zebrad: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zebra-script, zebrad.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gq4h-3grw-2rhv (GitHub-reviewed advisory GHSA-gq4h-3grw-2rhv lists affected ranges: crates.io zebra-script >=0 =0 <4.4.0)

Commands are suggestions: review each one before running it.

Loading voting…