Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)
CVE-2026-41887GHSA-xjvc-pw2r-6878
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/core 2.0.0-rc.1, 1.8.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist flarum/core
- Affected
- <= 1.8.15>= 2.0.0-beta.1, <= 2.0.0-beta.8
- Fixed in
- 2.0.0-rc.1, 1.8.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xjvc-pw2r-6878 lists affected ranges: Packagist flarum/core >=0 =2.0.0-beta.1 <=2.0.0-beta.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-41887: 0.47% estimated exploitation activity in the next 30 days; percentile 40.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the customless setting, but the same restriction was never applied to other settings registered as LESS config variables (for example themeprimarycolor and themesecondarycolor, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). Impact An attacker who has compromised — or legitimately obtained — an administrator account can: - Read arbitrary local files reachable by the PHP process (e.g. /etc/passwd, .env, config files…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xjvc-pw2r-6878
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41887 Advisory: Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577) IDs: CVE-2026-41887, GHSA-xjvc-pw2r-6878 Record: https://patchnext.com/advisories/cve-2026-41887 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flarum/core 2.0.0-rc.1, 1.8.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist flarum/core: affected <= 1.8.15; >= 2.0.0-beta.1, <= 2.0.0-beta.8; fixed in 2.0.0-rc.1, 1.8.16 ## Suggested inspection (read-only) - Packagist flarum/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flarum/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xjvc-pw2r-6878 (GitHub-reviewed advisory GHSA-xjvc-pw2r-6878 lists affected ranges: Packagist flarum/core >=0 =2.0.0-beta.1 <=2.0.0-beta.8) Commands are suggestions: review each one before running it.
Loading voting…