Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains
CVE-2026-41271GHSA-6r77-hqx7-7vw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.0; flowise 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 3.0.13
- Fixed in
- 3.1.0
npm flowise
- Affected
- <= 3.0.13
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6r77-hqx7-7vw8 lists affected ranges: npm flowise >=0 =0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6r77-hqx7-7vw8 lists affected ranges: npm flowise >=0 =0 <=3.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2026-41271: 0.23% estimated exploitation activity in the next 30 days; percentile 14.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. Details The vulnerability is located in FlowiseAI's API Chain implementation where user-controlled input is used to dynamically generate URLs and request parameters without proper validation. The attack works as follows: 1. Dynamic API Generation: Flowise's POST/GET API chains use LLM-generated prompts based on user queries and API documentation to construct HTTP requests 2. Unvalidated URL Construction: The system extracts URL and data parameters directly from LLM responses without validating against the intended API…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6r77-hqx7-7vw8
- Revision 1 · created ·
Published from osv record GHSA-6r77-hqx7-7vw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41271 Advisory: Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains IDs: CVE-2026-41271, GHSA-6r77-hqx7-7vw8 Record: https://patchnext.com/advisories/cve-2026-41271 (revision 2, source checked 26 Oct 2026, 12:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.0; flowise 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise-components: affected <= 3.0.13; fixed in 3.1.0 - npm flowise: affected <= 3.0.13; fixed in 3.1.0 ## Suggested inspection (read-only) - `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise-components, flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6r77-hqx7-7vw8 (OSV record GHSA-6r77-hqx7-7vw8 lists affected ranges: npm flowise >=0 =0 <3.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6r77-hqx7-7vw8 (GitHub-reviewed advisory GHSA-6r77-hqx7-7vw8 lists affected ranges: npm flowise >=0 =0 <=3.0.13) Commands are suggestions: review each one before running it.
Loading voting…