Skip to content

← Actionable
High, CVSS 7.7amended

Flowise: Parameter Override Bypass Remote Command Execution

CVE-2026-41268GHSA-cvrr-qhgw-2mm6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.0; flowise 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-41268: 17.44% estimated exploitation activity in the next 30 days; percentile 97.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODEOPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. Details The vulnerability is in a validation check within the replaceInputsWithConfig function within packages/server/src/utils/index.ts. The check for FILE-STORAGE:: was intended to handle file-type inputs but has three issues: 1. Uses .includes() instead of .startsWith(): The check passes if FILE-STORAGE:: appears ANYWHERE in the string, not just at the beginning. A remote user can embed it in a comment: / FILE-STORAGE:: / { custom config } 2. No parameter type validation: The check doesn't verify that the parameter is actually…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cvrr-qhgw-2mm6

  2. Revision 1 · created ·

    Published from osv record GHSA-cvrr-qhgw-2mm6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41268

Advisory: Flowise: Parameter Override Bypass Remote Command Execution
IDs: CVE-2026-41268, GHSA-cvrr-qhgw-2mm6
Record: https://patchnext.com/advisories/cve-2026-41268 (revision 2, source checked 26 Oct 2026, 12:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.0; flowise 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-components: affected <= 3.0.13; fixed in 3.1.0
- npm flowise: affected <= 3.0.13; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-components, flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cvrr-qhgw-2mm6 (OSV record GHSA-cvrr-qhgw-2mm6 lists affected ranges: npm flowise >=0 =0 <3.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cvrr-qhgw-2mm6 (GitHub-reviewed advisory GHSA-cvrr-qhgw-2mm6 lists affected ranges: npm flowise >=0 =0 <=3.0.13)

Commands are suggestions: review each one before running it.

Loading voting…