Flowise: Airtable_Agent Code Injection Remote Code Execution Vulnerability
CVE-2026-41265GHSA-v38x-c887-992f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.0; flowise 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 3.0.13
- Fixed in
- 3.1.0
npm flowise
- Affected
- <= 3.0.13
- Fixed in
- 3.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v38x-c887-992f lists affected ranges: npm flowise >=0 =0 <=3.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v38x-c887-992f lists affected ranges: npm flowise >=0 =0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-41265: 0.57% estimated exploitation activity in the next 30 days; percentile 47.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ZDI-CAN-29412: FlowiseAI Flowise AirtableAgent Code Injection Remote Code Execution Vulnerability Trend Micro's Zero Day Initiative has identified a vulnerability affecting the following products: Flowise - Flowise -- VULNERABILITY DETAILS ------------------------ Version tested: 3.0.13 Installer file: hxxps://github.com/FlowiseAI/Flowise Platform tested: Ubuntu 25.10 --- Analysis FlowiseAI Flowise Airtable Agent pythonCode Prompt Injection Remote Code Execution Vulnerability This vulnerability allows remote attackers to execute arbitrary code on affected installations of FlowiseAI Flowise. Authentication is not required to exploit this vulnerability. The specific flaw exists within the run method of the AirtableAgents class. The issue results from the lack of proper sandboxing when evaluating an LLM generated python script. An attacker can leverage this vulnerability to execute code in the context of the user running the server. Product information FlowiseAI Flowise version 3.0.13…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-v38x-c887-992f
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-v38x-c887-992f
- Revision 1 · created ·
Published from ghsa record GHSA-v38x-c887-992f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41265 Advisory: Flowise: Airtable_Agent Code Injection Remote Code Execution Vulnerability IDs: CVE-2026-41265, GHSA-v38x-c887-992f Record: https://patchnext.com/advisories/cve-2026-41265 (revision 4, source checked 26 Oct 2026, 12:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.0; flowise 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise-components: affected <= 3.0.13; fixed in 3.1.0 - npm flowise: affected <= 3.0.13; fixed in 3.1.0 ## Suggested inspection (read-only) - `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise-components, flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v38x-c887-992f (GitHub-reviewed advisory GHSA-v38x-c887-992f lists affected ranges: npm flowise >=0 =0 <=3.0.13) - Verified: https://osv.dev/vulnerability/GHSA-v38x-c887-992f (OSV record GHSA-v38x-c887-992f lists affected ranges: npm flowise >=0 =0 <3.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…