Skip to content

← Actionable
Critical, CVSS 9.9amended

Flowise: Authenticated RCE Via MCP Adapters

CVE-2026-40933GHSA-c9gw-hvqq-f33r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.1.0; flowise 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-40933: 11.96% estimated exploitation activity in the next 30 days; percentile 96.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Due to unsafe serialization of stdio commands in the MCP adapter, an authenticated attacker can add an MCP stdio server with an arbitrary command, achieving command execution. Details The vulnerability lies in a bug in the input sanitization from the “Custom MCP” configuration in http://localhost:3000/canvas - where any user can add a new MCP, when doing so - adding a new MCP using stdio, the user can add any command, even though your code have input sanitization checks such as validateCommandInjection and validateArgsForLocalFileAccess, and a list of predefined specific safe commands - these commands, for example "npx" can be combined with code execution arguments ("-c touch /tmp/pwn") that enable direct code execution on the underlying OS. https://github.com/FlowiseAI/Flowise/blob/d848baeb6bd9737a1e7fc912349c45fbdcc7bb38/packages/components/nodes/tools/MCP/core.ts#L223…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c9gw-hvqq-f33r

  2. Revision 2 · amended ·

    Amended from osv record GHSA-c9gw-hvqq-f33r

  3. Revision 1 · created ·

    Published from ghsa record GHSA-c9gw-hvqq-f33r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40933

Advisory: Flowise: Authenticated RCE Via MCP Adapters
IDs: CVE-2026-40933, GHSA-c9gw-hvqq-f33r
Record: https://patchnext.com/advisories/cve-2026-40933 (revision 3, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.1.0; flowise 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-components: affected <= 3.0.13; fixed in 3.1.0
- npm flowise: affected <= 3.0.13; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-components, flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c9gw-hvqq-f33r (GitHub-reviewed advisory GHSA-c9gw-hvqq-f33r lists affected ranges: npm flowise >=0 =0 <=3.0.13)
- Verified: https://osv.dev/vulnerability/GHSA-c9gw-hvqq-f33r (OSV record GHSA-c9gw-hvqq-f33r lists affected ranges: npm flowise >=0 =0 <3.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…