Skip to content

← Actionable
High, CVSS 8.7amended

smtp-server's command parser memory exhaustion denial-of-service

CVE-2026-38728GHSA-fv2f-rw9f-v9cm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (smtp-server 3.18.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-38728: 0.57% estimated exploitation activity in the next 30 days; percentile 47.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

smtp-server prior to v3.18.3 are vulnerable to unauthenticated memory exhaustion denial-of-service. smtp-server's command parser allows any remote client to consume server memory by sending data without newline characters. The server's remainder buffer in SMTPStream.write grows without limit, leading to heap exhaustion, prolonged GC pauses that freeze the event loop, and in some cases, process crash. The write method in lib/smtp-stream.js appends incoming TCP chunks to this.remainder in command mode. The buffer is only emptied when a newline is found. If a client never sends a newline, the remainder value will grow indefinitely, causing excess memory consumption.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fv2f-rw9f-v9cm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fv2f-rw9f-v9cm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-38728

Advisory: smtp-server's command parser memory exhaustion denial-of-service
IDs: CVE-2026-38728, GHSA-fv2f-rw9f-v9cm
Record: https://patchnext.com/advisories/cve-2026-38728 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: smtp-server 3.18.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm smtp-server: affected < 3.18.3; fixed in 3.18.3

## Suggested inspection (read-only)
- `npm ls smtp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on smtp-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fv2f-rw9f-v9cm (OSV record GHSA-fv2f-rw9f-v9cm lists affected ranges: npm smtp-server >=0 <3.18.3 (fixed))
- Verified: https://github.com/advisories/GHSA-fv2f-rw9f-v9cm (GitHub-reviewed advisory GHSA-fv2f-rw9f-v9cm lists affected ranges: npm smtp-server >=0 <3.18.3)

Commands are suggestions: review each one before running it.

Loading voting…